Lightroom CC: Cannot set album cover to an image when once it is part of a stack

  • 1
  • Idea
  • Updated 3 weeks ago
  • (Edited)
I have an album with 50 pictures and like 10 stacks. I have rated all of them and set a cover image for every stack. Now I want to set a cover image for my album.

Here is what happens:

  1. I right-click on the cover image of a stack (containing 5 more photos) and chose "set album cover"
  2. The album cover either doesn't change (if no album cover was set) or it updates to the default grey album cover icon
  3. When I pop-out the stack view and right-click on the image I want to use as album cover, there is no "set as... X" option for either stack or album.
When I try an image that is not part of a stack, it works fine and updates the album cover instantly.

A way around is right now is to ungroup the stack, right-click the desired album cover image, select "set as album cover" (the album cover instantly updates) and then regroup the stack.

I find this cumbersome and it would be great to have a "set as album cover" in addition to "set as stack cover" within the stack pop-up strip (makes most sense to me) as well as defaulting to the stack cover image if the user selects the stack in the grid view.

I tested this on macOS 10.14 Mojave. Will try on my Windows 10 machine later.
Photo of Floris van Eck

Floris van Eck

  • 34 Posts
  • 11 Reply Likes
  • there is a way around it but still would like fix

Posted 3 weeks ago

  • 1
Photo of Floris van Eck

Floris van Eck

  • 34 Posts
  • 11 Reply Likes
Update: Windows 10 (October update) exhibits the same behavior.