Photoshop: After switching from Wacom tablet to mouse, every click on canvas area gets lag (latest CC & CS6) on Win 7/8

  • 20
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
In Photoshop CC and CS6 (only if latest update has been applied, apparently), mouse clicks on the canvas area (*not in menus or palettes*) are lagged after using a Wacom tablet. Detailed explanation:

• When starting Photoshop, mouse works okay. Then, if I switch to my Intuos Pro (latest drivers), everything is fine too.
• But here comes the problem: when I switch back to the mouse, the very first mouse click (after switching from tablet) is NOT lagged, but the rest from then on, ARE.
• If the switch from tablet to mouse is done very quickly (clicking on canvas or ruler area with the pen while swiftly clicking with the mouse), then the lag does not happen.
• Closing Photoshop and re-opening it gets rid of the lag, until the tablet is used (then the problem starts again when switching to the mouse).

This problem has been debated here: http://forums.adobe.com/message/5768548
It has also been repeteadly reported to Wacom, who have not acknowledged or denied the problem: http://forum.wacom.eu/viewtopic.php?f...
User pinkbunkadoo posted a 15 sec video demonstrating the problem: https://www.youtube.com/watch?v=1D51R...

While the knowledgeable Chris Cox suggested that this seems a driver issue, we (the affected users) still believe that something changed in the latest Photoshop versions that brought up this problem, since it does not happen at all with CS6, CS5, etc. (although CS6 with latest updates seems to have the problem too). It doesn't happen either with a couple other pressure-sensitive design programs I've tried (ArtRage and SmoothDraw).

I've been able to reproduce this problem in all the machines I've tried it on (Win 7 and Win 8 systems), which do not seem to share any particular software or hardware that suggests a pattern. I've tried reinstalling the OS twice to no avail. My main machine is Win 8.1 x64, i7 930@2.8, 20 MB RAM, gfx card ATI Radeon HD 6800 series, and using Photoshop CC latest version (14.2.1).

This bug is extremely annoying for people like me that switch a lot between mouse and pen (I use mouse with my right hand, for menus, marquee selections, paths, etc., and the pen with my left hand to draw with brush tools). I'm more than willing to provide any additional info, should Adobe staff be kind enough to look into this or at least try to reproduce this issue. Thanks.
Photo of Carlos Oliveras

Carlos Oliveras

  • 103 Posts
  • 27 Reply Likes
  • very frustrated

Posted 4 years ago

  • 20
Photo of Christian Hayungs

Christian Hayungs

  • 23 Posts
  • 1 Reply Like
This problem exists for MONTH now, but neither Wacom or Adobe are doing anything about it or even acknowledge it.

Please finally solve this basis bug. I'm paying good money for your products.
Photo of nathan skrepcinski

nathan skrepcinski

  • 2 Posts
  • 0 Reply Likes
I'm having this problem as well with Photoshop CC and an Intuos4. This really needs to be solved.
Photo of Catalin Petolea

Catalin Petolea

  • 2 Posts
  • 4 Reply Likes
Photoshop CC and Intuos 5. Same bug. Latest drivers installed, to no avail. Mouse lags after using tablet. I also have a very high-end computer.
Please do something, Adobe.
Photo of Carlos Oliveras

Carlos Oliveras

  • 103 Posts
  • 27 Reply Likes
UPDATE: Some days after posting this problem, Wacom finally acknowledged this bug. They say they will fix it in a future update:

http://forum.wacom.eu/viewtopic.php?f...

(Anyway, please keep clicking the "me too" button if you have this problem, just in case - thanks)
Photo of Carlos Oliveras

Carlos Oliveras

  • 103 Posts
  • 27 Reply Likes
Bad news - Wacom seems to be backing off from their initial words. There's been no further info for a month and they say there's no further info. In fact, they somehow suggest that the problem might be on Adobe's end. It seems as if they' (Wacom) are not planning on fixing anything, since they recommend that we avoid using the mouse altogether as a way to avoid the lag (???):

____________________________________________________________
Re: Mouse click lag when switching from pen to mouse in PS C
by Wacom » Thu 12. Jun 2014, 14:21

The known problem is with the mouse after using the pen in CC. If you only
navigate with the pen, it should be fine. I have no further info on this at the
moment.
____________________________________________________________

So... anybody reading this and suffering from this issue, please keep clicking the +1 button.
Photo of Carlos Oliveras

Carlos Oliveras

  • 103 Posts
  • 27 Reply Likes
Still worse news - Adobe has changed something in Photoshop CC 2014 and now the lag is apparently gone, but there's no pressure sensitivity when using the tablet!! Pressure sometimes works in absolute mode (pen mode), never at all in relative mode (mouse mode). Of course, this might not be happening for everybody, but it is for me and more people. Pressure sensitivity was never an issue so far.

It is possible to recover pressure sensitivity by doing what you can read here:

https://forums.adobe.com/thread/1502616

It works, but guess what, then you have the pen-mouse switch lag AGAIN.

Wacom says the problem should not happen if we turn "Use Windows ink" on (it's a setting found in the Projection tab). Strange, since so far, we had been told by Wacom that "windows ink" was evil and should be disabled to avoid lag, so... wtf??? Anyway, turning it on or off does nothing for me regarding pressure sensitivity or lag.

Personally, I've given up on any hope of seeing this issue fixed anytime soon, if ever at all.
Photo of David Bleja

David Bleja

  • 45 Posts
  • 2 Reply Likes
I have the latest Photoshop and wacom driver as of writing, but I still get this problem.

Anyone else?
Photo of Christian Hayungs

Christian Hayungs

  • 23 Posts
  • 1 Reply Like
Yeah, problem STILL consists. Adobe and Wacom just don't care.
Photo of David Bleja

David Bleja

  • 45 Posts
  • 2 Reply Likes
It's incredible. I first saw this problem reported over a year ago, and it still remains unresolved. I can semi-understand Adobe ignoring this. They have a million things on their plate, and as a result Adobe software often has had flaws that took years to iron out.

But it shocks me that Wacom hasn't solved this, considering it affects such a core part of their business. Without fluid productivity, their products are nothing. For me, the problem arose when I upgraded from an Intuos 3 to an Intuos Pro, but now I'm seriously considering returning the Intuos Pro, since it has downgraded my overall experience.

Even if the problem is inside Photoshop, you'd think Wacom by now would have harangued Adobe until they fixed it on their end.
Photo of mihkeltt

mihkeltt

  • 2 Posts
  • 0 Reply Likes
There is a workaround for photoshop. Apparently CC 2014 changed the way it communicates with windows api. In order to get the tablet to work properly, you need to disable "Use windows ink" in the Wacom Preferences utility, then create a user configuration file for photoshop as outlined in this forum post:

http://forum.wacom.eu/viewtopic.php?f...

Completing these steps removes all lag issues and the annoying Ctrl, Shift and Alt hints, keeps pressure sensitivity in photoshop and generally keeps the wacom tablet working as it should.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
On Windows 8, you should leave Ink enabled a not disable the tablet API unless you have a third party device that doesn't use the Windows APIs correctly.
On Windows 7, you will always be using the older WInTab API.
Photo of Carlos Oliveras

Carlos Oliveras

  • 102 Posts
  • 27 Reply Likes
mihkeltt: Thanks, but isn't that the same info I already posted a little above? Anyway, that method is intended not to fix the lag, but to recover the lost pressure sensitivity of the new API. And indeed it works, pressure sensitivity works again, but then the lag, which is the issue here, is back too.

Chris Cox: Thanks a lot for dropping by, your insight as well as your time is very very highly valued. The problem is that leaving the tablet API enabled (the one that comes by default in PS CC 2014) we lose pressure sensitivity in certain scenarios:

- If the tablet is set to relative positioning mode (so called "mouse" mode), pressure sensitivity won't work at all in PS CC 2014 (it did work in CC 14.2.1).

- If the tablet is set to absolute positioning (pen mode), sometimes pressure does work, sometimes it does not, and I can't find the reason why.

But in both cases, pressure is being correctly read by the diagnostics section of the Wacom driver interface. So the pressure information seems to be there, it's just that, for some reason, it seems not to be getting through to Photoshop CC 2014.

So, in short, it seems that either we have the mouse-pen switch lag, or we lose pressure sensitivity randomly, at least in relative positioning mode.

I've abandoned all hope on this thing being fixed by Wacom or Adobe, but seeing your name here makes me think that perhaps that miracle is still possible, although I don't know if people at Adobe have been able to reproduce this kind of issues (the lag with the "old" api, and the lack of pressure sensitivity with the new one, at least in relative positioning mode).

By the way, turning windows ink on/off does not seem to make any difference to me.

Again, thanks for your comment and for all your work and help in the past.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
OK, then you need to work with Wacom to see why their driver is failing for you.
The Ink API should be working fine, but a few people are having problems - especially with older Wacom drivers.
Photo of Carlos Oliveras

Carlos Oliveras

  • 102 Posts
  • 27 Reply Likes
Yes Wacom says they are looking into it, but some weeks ago I gave up. I'll have to live with this or wait for new drivers. Thanks a lot again.
Photo of David Bleja

David Bleja

  • 45 Posts
  • 2 Reply Likes
I get the mouse lag problem whether or not I have "use windows ink" checked or not. And I've tried creating the PSUserConfig.txt file as mihkeltt suggested, and that didn't remove the lag either.

Carlos, so the lag has disappeared for you since CC 2014? What settings/specs are you using?

I'm using Win 7 Home 64, Intuous Pro, Wacom driver version 6.3.8-4
Photo of Carlos Oliveras

Carlos Oliveras

  • 103 Posts
  • 27 Reply Likes
David: For me, the lag when switching disappears in CC 2014, but pressure sensitivity is also gone, so one thing is fixed and another one is broken. This happens without any special setting, just by upgrading to CC 2014 and using the tablet.

To recover pressure sensitivity in version 2014, I have to do the trick I already mentioned (create a file -psuserconfig.txt- in a specific directory, etc.). Then pressure sensitivity works again in PS CC 2014, but then the lag also starts hapenning again when switching from pen to mouse.

I'm using Win 8 Pro, Intuos Pro with latest drivers.
PS CC 14.2.1: everything ok, but lag when switching from pen to mouse.
PS CC 2014: everything ok, but no pressure sensitivity. If I use pen mode (absolute positioning), it sometimes detects pressure (it has to work from the start, or it won't work at all during that session). But in relative positioning mode ("mouse" mode), which is what I want to use, pressure hasn't worked a single time in CC 2014. If I do the psuserconfig.txt trick, then it's back to how it worked in 14.2.1 (with pressure sensitivity both for absolute/relative positioning mode, but also with lag).
Photo of David Bleja

David Bleja

  • 45 Posts
  • 2 Reply Likes
Thanks for clarifying. Perhaps CC2014 only fixes it on Win 8. If so, I wonder whether Adobe fixed the lag in win 8 on purpose, or by fluke.
Photo of Ânderson

Ânderson

  • 2 Posts
  • 0 Reply Likes
In any other PS everything works fine without mark "Windows Ink"

In PS CC 2014 pressure only works if I mark "Windows Inks" , but is very laggy.

Especially when I use the Pen Tool (P)

Adobe needs to solve this problem. It's a shame to say that the problem is the wacom.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 764 Reply Likes
So far, the problem does appear to be with the driver, and many people have solved it by updating the driver or reinstalling the driver.
Photo of Christian Hayungs

Christian Hayungs

  • 23 Posts
  • 1 Reply Like
Where did you get that info from? As far as I've followed the forums updating the driver does NOT solve any problems with the lag. In some cases it causes it.

This mouse-lag problem persists for about a year now and neither wacom or adobe doing anything about it.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 764 Reply Likes
From multiple forums and multiple discussions with customers experiencing problems with their tablet drivers.
Photo of David Bleja

David Bleja

  • 43 Posts
  • 1 Reply Like
The latest wacom driver (6.3.9w3) seems to have resolved the issue for me. ( Win 7 Home 64bit, Intuos Pro, Photoshop CC2014 version 20140731.r.148 x64). Though it doesn't seem to fix it for everyone.

From my googling, it seems that this problem was first reported a year and a half ago. It's pretty dismal that both companies have allowed the problem to drag on this long. I'm very relieved that it's finally fixed for me though.
Photo of nathan skrepcinski

nathan skrepcinski

  • 2 Posts
  • 0 Reply Likes
Still experiencing pen-mouse lag here with an Intous4 (driver 6.3.9w3) and Photoshop CC 2014 (20140730.r.148 x64) on Win 7 Pro. PSUserconfig.txt did nothing.

Only thing that seems to have gotten better is that originally I believe the lag affected panning and zooming, but that is now gone. However, there's still almost a full second from when I press the mouse button to Photoshop drawing a stroke...
Photo of Carlos Oliveras

Carlos Oliveras

  • 103 Posts
  • 27 Reply Likes
Since I started this topic, I want to say that as of today, the problem is not happening for me anymore. Apparently, it got fixed with the latest driver version from Wacom, applied with the latest Photoshop CC version, but I've waited some weeks before saying anything, to make sure it is indeed working. Well, not 100%: now there's a different bug - sometimes, when using brush tools, a straight line is drawn from one point to the other when holding the pen over the tablet just after switching from mouse to pen. It's amazing these Wacom people ain't able to do a d-rn thing right once and for all. I'm sorry, I respect and appreciate their work but they just don't cut it. At least the new bug isn't even remotely as annoying as the lag bug. In fact, there's even a newer driver version which appeared shortly after the one I'm using, and I haven't dared to update to it because I'm sure it will break a different thing, and I am fine as I am right now.

Still, it wouldn't surprise me a bit if the problem started happening again (Windows 9 cames out, we have to update the Wacom drivers and there we go again). It has been an really, really, really crippling issue for many people like me for over one year, and we are still waiting for somebody from Wacom (or Adobe, or both) to say: "yes, there was a problem caused by "x", and we solved it, sorry". It appears to be something that no one has considered important enough to seriously look into it, That speaks volumes for iself - in fact, even Wacom took more than half a year to just mildly acknowledge the problem, and currently their staff is almost missing from what used to be a support forum.

I don't know if these threads-topics (here and at wacom's) played some role in the bug being noticed and fixed, but like I was saying, if it were to happen again, to h-ll with it. I'm not losing more time running around forums and the likes feeling like I'm talking to the wind (specially regarding Wacom - at least Chris Cox from Adobe joined the discussion, here and also at adobe forum's, and I'm seriously thankful for that, not that I can say the same for Wacom).

I truly wish this issue has gone away also for the rest of you. Otherwise, you're on your own. We've always been.

Best of luck for you.
Photo of David Bleja

David Bleja

  • 45 Posts
  • 2 Reply Likes
I agree that the most incredible thing about the whole thing is the apparent blase attitude of Wacom and Adobe about this. We can only assume that this happened to a tiny proportion of users, but still.

I suppose that's what happens when a company has a near-monopoly. As hugely annoying as the problem was, I doubt many of us were prepared to go buy a non-wacom tablet and use it with Gimp.
Photo of Christian Hayungs

Christian Hayungs

  • 23 Posts
  • 1 Reply Like
Thats right. Lag is gone between strokes and actions, but now the right-click brush menu is broken. I can't drag the sliders anymore, have to tip them or punch in the numbers.
I wonder if wacom and Adobe even use their own products...
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14149 Posts
  • 1765 Reply Likes
What OS/version are you on?
Do you have the latest driver installed? (6.3.10w2)
Do you have the latest updates for Photoshop installed? http://adobe.ly/PS-Up-To-Date
Photo of Christian Hayungs

Christian Hayungs

  • 23 Posts
  • 1 Reply Like
Windows8 64bit
and of course: latest Wacom Driver, latest PS CC2014 Version

The Right-Click-Menu lag only apears, when you use it with tablet-pen.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13977 Posts
  • 1668 Reply Likes
Have you tried restoring your preferences?: http://blogs.adobe.com/crawlspace/201...

If you do restore your prefs, please save a copy of your existing prefs in case they turn out to be the culprit. Having the bad prefs can sometimes help us track down the issue.
Photo of Christian Hayungs

Christian Hayungs

  • 23 Posts
  • 1 Reply Like
The link doesn't load.
But nontheless, resetting prefs doesn't change anything.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14149 Posts
  • 1765 Reply Likes
The engineering team is looking into this.
Photo of tobias mayr

tobias mayr

  • 1 Post
  • 0 Reply Likes
Any news? This is a daily nuisance.
Photo of David Bleja

David Bleja

  • 45 Posts
  • 2 Reply Likes
Actually, Christian, they've been failing to fix this for almost 2 years already:

https://forums.adobe.com/thread/1228545
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14149 Posts
  • 1765 Reply Likes
Can you confirm what exact version of Photoshop you are running? CC 2014.2.2 is the latest. http://adobe.ly/PS-Up-To-Date
Photo of georg hilmarsson

georg hilmarsson

  • 10 Posts
  • 1 Reply Like
This is still happening on my system. I am running windows 7 and photoshop cs6 (13.0.1 64bit) - latest wacom driver.

The problem doesn ́t exist in cs5 - So I have just started using that again :(