Camera Raw: Adjustments in ACR are not working in macOS Catalina. Not able to use the eraser brush nor to create a new adjustment

  • 4
  • Problem
  • Updated 2 months ago
  • Acknowledged
  • (Edited)
After updating to OS Catalina the adjustments in Camara Raw filter are not working properly. I can make only one adjustment, but I am not able to use the eraser brush nor to create a new adjustment b rush/filters or others.
Photo of Hernán

Hernán

  • 2 Posts
  • 0 Reply Likes

Posted 2 months ago

  • 4
Photo of George Vasilopoulos

George Vasilopoulos

  • 6 Posts
  • 0 Reply Likes
I am having the same issue re the adjustment brush erase function—after selecting, it reverts to ‘add’ when clicking/dragging. Option-click/drag also has no effect, when it should also erase.
(Edited)
Photo of David Franzen

David Franzen, Employee

  • 108 Posts
  • 28 Reply Likes
Hello,

I've been unable to reproduce this bug so far. Can you answer a few questions, which might help me out?

First of all--can you let us know exactly which Version of Camera Raw you are using? The version appears in the title bar of the Camera Raw preferences window.

Second, please let me know how the steps you follow differ from these.

1. With a document open in Photoshop, click on Filter menu > Camera Raw Filter
2. Click on the Adjustment Brush tool from the tool bar.
3. Click, holding down the mouse button, and drag across the photo, creating a brush stroke.
4. Release the mouse button.
5. Hold down the option key, click, holding down the mouse button and drag across the photo--erasing the brush stroke.

Does the bug happen consistently (or sometimes) when you follow these basic steps? If not, what additional steps are you doing before you see the bug?

Thanks for your help,
David
Photo of George Vasilopoulos

George Vasilopoulos

  • 6 Posts
  • 0 Reply Likes
Hi David, I am on ACR 11.4.1 (latest version). 

I have done further testing on other computers, accessing ACR from both Photoshop and Bridge as follows:

  • On a 2018 15” MacBook Pro 2.9 i9 with optional Radeon Pro Vega 20 graphics (my work computer) - choosing ‘erase’ from the adjustment brush panel or option-clicking/dragging do not work, reverting to ‘add’ in every instance.

  • On a 2018 13” MacBook Pro 2.7 i7 (my personal computer) - when choosing ‘erase’ from the adjustment brush panel it reverts to ‘add’ on the first click/drag. When option-clicking/dragging it works correctly.

  • On a 2014 15” MacBook Pro 2.8 i7 (my colleague’s work computer) - when choosing ‘erase’ from the adjustment brush panel it reverts to ‘add’ on the first click/drag. When option-clicking/dragging it works correctly.

I’ve noted William’s comments below about panoramas—will come back with notes once I’ve had a chance to test.

Many thanks
George
(Edited)
Photo of George Vasilopoulos

George Vasilopoulos

  • 6 Posts
  • 0 Reply Likes
Hi again, the panorama is as described below on both my 13” MBP and my colleague’s older 15”. Changing projection options does nothing. The boundary warp slider seems to work normally however.
Photo of George Vasilopoulos

George Vasilopoulos

  • 6 Posts
  • 0 Reply Likes
Photo of George Vasilopoulos

George Vasilopoulos

  • 6 Posts
  • 0 Reply Likes
Photo of Katkin

Katkin

  • 1 Post
  • 0 Reply Likes
Hello, I have the same problem with the adjustment brush erase function on Catalina, it converts back to 'add' every time I click or drag it. It works when I use the option key though. I'm on a 2013 iMac and I've tried installing an old version of ACR first, which still showed the same problem, so I reinstalled ACR 11.4.1 now.
(Edited)
Photo of William

William

  • 1 Post
  • 0 Reply Likes
The problem described happens for me exactly as George said. I have opened a DNG file from my desktop. I have done this countless time before with the previous ACR version and OS Mojave. It is happening with the ARC version 11.4.1 and OC Catalina.

Also, the projection choices do not work when creating a panorama. There is no change when you select the various choices as it did before. The image just stays the same preview regardless of selection made. Thx William
Photo of David Franzen

David Franzen, Employee

  • 108 Posts
  • 28 Reply Likes
Official Response
Thank you to everyone who shared additional info.

I have been able to reproduce the problem with the Erase radio button for the Adjustment Brush on my computer and have logged a bug for further investigation. I have not seen this problem happening when using the option key, however. I'm using the US keyboard layout--is it possible those having the problem with the option key are using a different layout?

-David
Photo of George Vasilopoulos

George Vasilopoulos

  • 6 Posts
  • 0 Reply Likes
Hi David I’m using a uk keyboard - perhaps this is specific to the i9 based 2018 MacBook Pro with the upgraded Radeon pro?
Photo of yael steren

yael steren

  • 1 Post
  • 0 Reply Likes
Ahh the option key works and is great until this gets solved! Thank you! 
Photo of Hernán

Hernán

  • 2 Posts
  • 0 Reply Likes
I bough my computer in Europe and currently I use the US keyboard display, and sometimes the Spanish one. I hope you can resolve this bug thing soon. Thanks for the option key tip.