Photoshop CC 2018: After latest update, "select and mask" tool gives program error

  • 14
  • Problem
  • Updated 8 months ago
  • Solved
  • (Edited)
After update, I am getting "Could not apply the workspace because of a program error" after clicking "select and mask" button. Before update, it worked perfectly. Have somebody same problem?
Photo of David Nogol

David Nogol

  • 8 Posts
  • 3 Reply Likes
  • frustrated

Posted 2 years ago

  • 14
Photo of Stephen Newport

Stephen Newport

  • 278 Posts
  • 87 Reply Likes
Think I found a solve literally right after I posted....


For kicks I unchecked "remember settings" in the select & mask dialogue, hit ok, now it appears to be functioning normally. I turned "remember settings" back on and it is still continuing to function normally.
So, for me, "remember settings" was causing the issue, but works after unchecking, hitting ok, and reapplying.
Photo of F.J. Gorrin Garcia

F.J. Gorrin Garcia

  • 1 Post
  • 0 Reply Likes
Great! It also woked out for me too! Thansk!
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 728 Posts
  • 340 Reply Likes
Hey Everyone,

Thanks for the helpful feedback. We're working on an update to address this issue in the very near future. In the meanwhile, uncheck "remember settings" or using 8 bit are both viable workarounds.

Thank you,
Hannah Nicollet
Photo of Ethan Tweedie

Ethan Tweedie

  • 6 Posts
  • 0 Reply Likes
This is such a nightmare.  How in the world are we supposed to get anything done with such a major flaw.  Very sad.