Photoshop CC 2018: After latest update, "select and mask" tool gives program error

  • 14
  • Problem
  • Updated 9 months ago
  • Solved
  • (Edited)
After update, I am getting "Could not apply the workspace because of a program error" after clicking "select and mask" button. Before update, it worked perfectly. Have somebody same problem?
Photo of David Nogol

David Nogol

  • 8 Posts
  • 3 Reply Likes
  • frustrated

Posted 2 years ago

  • 14
Photo of Pete Green

Pete Green, Customer Advocate

  • 753 Posts
  • 147 Reply Likes
Hi David,

Sorry for the Program Error with Select and Mask. Program errors can be finicky, and at times restoring the preferences to the default state can be a fix for errors like this. Have you tried that yet?

Reset Photoshop preferences: https://helpx.adobe.com/photoshop/kb/basic-trouble-shooting-steps.html#prefs

Give that a try and let us know if it resolves it for you. 

Regards
Pete
(Edited)
Photo of David Nogol

David Nogol

  • 8 Posts
  • 3 Reply Likes
Hi Pete, thank you for quick reply. I tried reseting preferences and it helped. Now it seems select and mask is working again :) Thank you!
Photo of Pete Green

Pete Green, Customer Advocate

  • 753 Posts
  • 147 Reply Likes
Awesome, thanks for the update David -- Glad that worked, and I hope it sticks. Let us know if it comes back!
Photo of David Nogol

David Nogol

  • 8 Posts
  • 3 Reply Likes
After editing few photos, I get same error message :( I must find a way how to install older version which worked perfectly
Photo of Edwin Virden

Edwin Virden

  • 1 Post
  • 0 Reply Likes
I had the same problem and changed mode to 8 bit and it works now!
Photo of Sherburn Sanborn

Sherburn Sanborn

  • 1 Post
  • 0 Reply Likes
I'm having the same problem in cc 2018. Reinstalled 2017 and using the same image with an active selection, Select & Mask works fine.
Photo of Steve Candi

Steve Candi

  • 6 Posts
  • 0 Reply Likes
same error. changing to 8 bit mode fixed this.
Photo of Fran Solly

Fran Solly

  • 1 Post
  • 0 Reply Likes
Same error and changing to 8 bit worked - thank you!!
Photo of Andi Möller

Andi Möller

  • 4 Posts
  • 0 Reply Likes
Its happened by me too, but only effects big files, like tiff, small ones , like jpeg are working normal. tryed with and without graphicprocessor
Photo of Pete Green

Pete Green, Customer Advocate

  • 752 Posts
  • 147 Reply Likes
Does the preference reset (mentioned above) help for your larger images Andi?
Photo of Andi Möller

Andi Möller

  • 4 Posts
  • 0 Reply Likes
yes , just i tried, and now it looks fine, thanks a lot from Germany ;-)
Photo of Andi Möller

Andi Möller

  • 4 Posts
  • 0 Reply Likes
Bad luck, today morning after Restart the problem appear again, same like before :-(
Photo of Steve Candi

Steve Candi

  • 6 Posts
  • 0 Reply Likes
Resetting preferences worked but then it came back. Changed to 8 bit mode and now works ok.   Try it guys
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 729 Posts
  • 341 Reply Likes
Hi David,

Do you have a channel selected when you attempt the Select and Mask?
Photo of David Nogol

David Nogol

  • 8 Posts
  • 3 Reply Likes
Hello Hannah, yes I have selected channel. Now it seems error occurs only sometimes.

At first, I selected object with quick selection tool. Then I clicked "select and mask" button and get error "Could not apply the workspace because of a program error".

Then I tried to select object manually with lasso tool and now "select and mask" works even with combination with quick selection tool.

Is there any way to get more specific information about errors in photoshop? I want to give more information, but don't know how :(
Photo of David Nogol

David Nogol

  • 8 Posts
  • 3 Reply Likes
And sometimes error occurs every time :( I have lot of photos to edit, so I am forced to use older version of Photoshop, which works fine.
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 729 Posts
  • 341 Reply Likes
We have had other user reports of program errors related to selecting channels and then getting a program error with select and mask. If a channel is selected in the channels panel, the command "Select and Mask" should be grayed out because one cannot do anything to a channel with this command. We're aware of it and engineering is looking into it, but in the meanwhile you will likely run into program errors if you attempt to use select and mask with channels.
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 729 Posts
  • 341 Reply Likes
As far as getting more information, thanks for the help! It's always nice to receive error reports so if you are prompted we appreciate you sending them.

You can also download the log collector here: 
https://helpx.adobe.com/creative-cloud/kb/cc-log-collector.html

That will create a file that helps us troubleshoot your problem.

Thanks! :) 
Hannah
Photo of THOMAS TESTI

THOMAS TESTI

  • 4 Posts
  • 3 Reply Likes
It has happened to me as well. If I do a select all, I do not get the error, but anything less gives this error. I tried using different selection tools and the same. I upgraded my Graphics Driver and reset preferences. I tried turning off Graphics Acceleration to no avail. The OpenCL was unchecked which what some on the web were saying to do. 

Also, I do not have any channels selected. It seems to work OK on JPEG's but not on Tiffs or PSD or Raw files (Canon CR2 or Nikon NEF). 

I am running Windows 10

Tom
Photo of THOMAS TESTI

THOMAS TESTI

  • 4 Posts
  • 3 Reply Likes
If I switch to 8-bit it works OK, but not 16 or 32-bit
Photo of THOMAS TESTI

THOMAS TESTI

  • 4 Posts
  • 3 Reply Likes
I did as Stephen Newport said below to uncheck the remember settings and it worked. Re-checked the remember settings and it still works...so far...
Photo of Art-Mark Ink

Art-Mark Ink

  • 4 Posts
  • 2 Reply Likes
Getting same error, on my sony raw files, switched to 8bit as mentioned above and it works... cc 17 worked great

macbook pro
Photo of Stephen Newport

Stephen Newport

  • 281 Posts
  • 87 Reply Likes
Same error here.
Photo of Lenin Laviña

Lenin Laviña

  • 2 Posts
  • 0 Reply Likes
Same error here plus weird mask patterned artifacting
Photo of Garrett Wood

Garrett Wood

  • 1 Post
  • 0 Reply Likes
Same error here. Last version worked fine
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 729 Posts
  • 341 Reply Likes
We're trying to reproduce the error on our end but it isn't happening with the test files we have used.

Anyone who is getting this error, would you share a file that is encountering the error? It would also be helpful to include the steps you took before it happened.

Thank you!
Hannah
Photo of Stephen Newport

Stephen Newport

  • 278 Posts
  • 87 Reply Likes
This happens on start of the program with every file, whether opened from a raw Lightroom export, or a new document when initiating select & mask via shortcut or file menu on a selection.
Select & mask works as expected when initiated from an existing mask.
Photo of Art-Mark Ink

Art-Mark Ink

  • 4 Posts
  • 2 Reply Likes
Would you like it posted to this thread or do you have an email we can send one to?
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 729 Posts
  • 341 Reply Likes
Either way. If you would prefer to keep it off the thread, please send it to me at:



Thank you,
Hannah
Photo of Art-Mark Ink

Art-Mark Ink

  • 4 Posts
  • 2 Reply Likes
I emailed it, thanks! 
Photo of Stephen Newport

Stephen Newport

  • 278 Posts
  • 87 Reply Likes
After turning off "remember settings" I've only had it happen once now and hasn't repeated... I'll upload the next file it happens to
Photo of Andi Möller

Andi Möller

  • 4 Posts
  • 0 Reply Likes
Hi Nicollet,
i investigate in the last days a little bit. The failure only occurs if in selection tool the (in german) Kantenerkennung, in mask selection tool is changed for examble to 10 px. And the settings are saved. If i use a saved file of the preferences without this change of the "Kantenerkennung" everything works fine.
Photo of Stephen Newport

Stephen Newport

  • 281 Posts
  • 87 Reply Likes
Think I found a solve literally right after I posted....


For kicks I unchecked "remember settings" in the select & mask dialogue, hit ok, now it appears to be functioning normally. I turned "remember settings" back on and it is still continuing to function normally.
So, for me, "remember settings" was causing the issue, but works after unchecking, hitting ok, and reapplying.
Photo of F.J. Gorrin Garcia

F.J. Gorrin Garcia

  • 1 Post
  • 0 Reply Likes
Great! It also woked out for me too! Thansk!
Photo of Art-Mark Ink

Art-Mark Ink

  • 4 Posts
  • 2 Reply Likes
Same here, my very first run after the update I opened a raw file from lightroom export, used the select and mask tool loaded right up and worked fine. Finished that file opened up a second raw file from the same session and upon my second attempt to run the select and mask tool it threw the error and continued to do so there after. Switch to 8bit it works, or uncheck remember settings it works.  
(Edited)
Photo of Matt Greenslade

Matt Greenslade

  • 36 Posts
  • 5 Reply Likes
Switching to 8-bit seemed to work for me. No luck with unchecking remember settings. These bugs are crazy. This and healing brush too! The shareholders may love the subscription model but dealing with the constant bugs is wasting a huge amount of my time.
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 729 Posts
  • 341 Reply Likes
Would you mind posting a file that is giving you trouble? We have been trying to replicate the program error but so far haven't encountered it.

Thanks,
Hannah
Photo of eartho

eartho, Champion

  • 1239 Posts
  • 387 Reply Likes
Looks like any 16bit image will provoke the bug...
Photo of peter smart

peter smart

  • 1 Post
  • 0 Reply Likes
This reply was created from a merged topic originally titled Getting a program error with Select and Mask.

select and mask not working, getting an error message saying: COULD NOT APPLY THE WORKSPACE BECAUSE OF A PROGRAM ERROR

Please advise
Photo of benjamin thomas

benjamin thomas

  • 1 Post
  • 0 Reply Likes
Same with me very very frustrating, Adobe should have this sorted before making the update
Photo of Beckijo

Beckijo

  • 1 Post
  • 0 Reply Likes
I'm getting the same error, I tried to uncheck remember settings and it's not helping, it actually made Photoshop crash.. this is why I hate it when they come out with updates... ugh
Photo of rogéz

rogéz

  • 10 Posts
  • 4 Reply Likes
This reply was created from a merged topic originally titled Refine Edge (select & mask) initialise error since PS19 upgrade.

error message: "Could not apply the workspace because of a program error." appearing after making a selection and pressing the select & mask button in the toolbar. I get this error since upgrading to PS19.

Please provide another solution than deleting your preferences as I do not wish to do that. I have to many customisations and would loose too much time setting them all back. Can I maybe delete one singe preference regarding this specific error?
Photo of rogéz

rogéz

  • 10 Posts
  • 4 Reply Likes
Like mentioned above (thanks alot!) follow these steps:
(do this with an non-important image)
  1. convert your image to 8bpc
  2. make a selection
  3. refine your selection
  4. uncheck "save settings" and hit ok
  5. convert your image back to 16bpc
  6. make a selection
  7. refine the selection (now it works!)
  8. you can safely check "save settings" again
  9. hit ok
  10. fixed!
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 729 Posts
  • 341 Reply Likes
Hey Everyone,

Thanks for the helpful feedback. We're working on an update to address this issue in the very near future. In the meanwhile, uncheck "remember settings" or using 8 bit are both viable workarounds.

Thank you,
Hannah Nicollet
Photo of Ethan Tweedie

Ethan Tweedie

  • 6 Posts
  • 0 Reply Likes
This is such a nightmare.  How in the world are we supposed to get anything done with such a major flaw.  Very sad.
Photo of Andrew Mayberry

Andrew Mayberry

  • 3 Posts
  • 0 Reply Likes
This reply was created from a merged topic originally titled "Edit in Photoshop" from LR causes "Select and Mask" error.

When I open an image in LR CC  Classic 2018 and select "Edit in Adobe Photoshop 2018" it opens fine (via Camera RAW etc).

However, when I select an area and click on Select and Mask, the error "Could not apply the workspace because of a program error." appears.  Opening the file directly works fine.

Photo of Andrew Mayberry

Andrew Mayberry

  • 3 Posts
  • 0 Reply Likes
Preference reset fixed the issue...
Photo of Steve Candi

Steve Candi

  • 6 Posts
  • 0 Reply Likes
Fixed it for me to but then it came back. Changing to 8 bit mode fixes this but we shouldnt have to do this. Im paying money for this..... Fix it Adobe.
Photo of Dana Lane

Dana Lane

  • 1 Post
  • 0 Reply Likes
I only encounter this when I attempt to edit a photo that I've touched in lightroom (with lightroom edits). Selecting the same raw file (without LR edits) and it works fine. 

I've reset the preferences and it worked for exactly 1 image. Then next image I tried this with resulted in the same issue.
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 729 Posts
  • 341 Reply Likes
Hi Everyone,

This should be resolved in the 19.0.1 update released last night. Please update Photoshop using the Creative Cloud desktop app, and let us know how it goes!

Regards,
Hannah
Photo of Stephen Newport

Stephen Newport

  • 278 Posts
  • 87 Reply Likes
Hi Hannah,
This fixes this particular issue, but it broke refining the edge from an alpha mask:

https://feedback.photoshop.com/photoshop_family/topics/select-mask-ignores-edge-detection-when-initi...
Photo of Mark English

Mark English

  • 1 Post
  • 1 Reply Like
Hannah,  It's Still broken at 19.0.1 under Win10.  I've tried EVERYTHING suggested in the community forums at Adobe etc. etc.  As soon as you begin refining a selection with "Select and Mask", PS appears to freeze.  Task Manager reports that PS is still using some CPU, etc... but it's essentially frozen; have to end PS with Task Manager.  Doesn't matter if image is 8-bit or 16.
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 729 Posts
  • 341 Reply Likes
Hi Mark,

Sorry to hear that. I'll reopen the case. I have been using select and mask on Win 10, v. 19.0.1 without getting a program error so I'd like to get closer to duplicating your situation. Would you mind sending me a psd that you have used to get the program error and if possible a screen capture of what happens when you attempt to do a select and mask? My email is below.

Thanks,
Hannah

Photo of Ana Espinho

Ana Espinho

  • 1 Post
  • 0 Reply Likes
Hi, I am using latest version of PS Cc and having the same problem. Already converted from 16 to 8 bit image, but still cracking. Can you help me?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16161 Posts
  • 2556 Reply Likes
Official Response
This issue should be fixed by the Photoshop CC 2018 (19.1) update that was released today.
Photo of richard

richard

  • 1 Post
  • 0 Reply Likes
I have PS 19.1.3 and I still have the issue