Photoshop: Advance Blending mode causes Crashing

  • 1
  • Problem
  • Updated 2 weeks ago
  • (Edited)
If I set Advanced Blending mode to Knockout: Shallow or Deep, then set the layer fill to 0% it causes the program to crash. I updated to 21.0.3 and the same issue occurs.

I was following this tutorial: https://clicks.aweber.com/y/ct/?l=Bln2a&m=3hbVhYaHjsxrHbi&b=76PRgZMW1A2uuZhqpZIQfw
Photo of Elizabeth Laws

Elizabeth Laws

  • 1 Post
  • 0 Reply Likes
  • sad, frustrated, annoyed

Posted 5 months ago

  • 1
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1530 Posts
  • 308 Reply Likes

What have you done for trouble-shooting so far? 

Restoring Preferences after making sure all customized presets like Actions, Patterns, Brushes etc. have been saved might be a good starting point:

https://helpx.adobe.com/photoshop/kb/basic-trouble-shooting-steps.html


Does turning off »Use Graphics Processor« in the Performance Preferences (Photoshop > Preferences > Performance > Graphic Processor Settings) and restarting Photoshop have any bearing on the issue? 
And the same for turning on Photoshop > Preferences > Performance > Legacy Compositing? 

Photo of Cristen Gillespie

Cristen Gillespie

  • 2055 Posts
  • 720 Reply Likes
It might also help if you said what OS you're using. I'm on Mac running Mojave, and I'm unable with several efforts to get it to crash. If what Christoph says doesn't help any,  if you also include a screenshot of your layers before you use Advanced Blending, with the layer targeted, it might help us spot if anything isn't quite right.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17068 Posts
  • 2906 Reply Likes
I found your crash log. Thanks for submitting. I may have some additional questions after discussing with engineering.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17068 Posts
  • 2906 Reply Likes
If you go to Preferences > Performance... and check "Legacy Compositing" does it work without crash?
Photo of Andrew Sender

Andrew Sender, Employee

  • 132 Posts
  • 59 Reply Likes
Hi Elizabeth,
I am trying to reproduce the crash you are describing.  Can I email you the file I'm work with, and you can try opening this file and changing the "Knockout" layer fill opacity from 100% to 0%?

Andrew
Photo of anna mujica

anna mujica

  • 1 Post
  • 0 Reply Likes
Just wanted to let you all know that I had the same problem.  I use Windows 10 on a PC. When I changed the preferences to 'Legacy Compositing' as described above, the crash was eliminated. 
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 17060 Posts
  • 2902 Reply Likes
Hi Anna, Can you please submit your Crash Reports along with your email address: https://helpx.adobe.com/photoshop/kb/submit-crash-reports.html We're trying to confirm you're seeing the same issue with 21.2