Adobe Bridge CC 6.1 not launching on MacOS 10.6.8 (not a supported OS version)

  • 5
  • Problem
  • Updated 4 years ago
  • (Edited)
I just updated Adobe Photoshop and now Bridge CC cannot be opened because of a problem.It says to check with the developer to make sure Adobe Bredge CC works with this version of Mac OS X. Adobe Photoshop will open.
Photo of Cathy Zaremba

Cathy Zaremba

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 4 years ago

  • 5
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Official Response
We'll have to do some testing.
But it looks like MacOS 10.6.8 is too old to run Bridge 6.1.

And you might want to read the system requirements: https://creative.adobe.com/products/b...
Where it clearly says that the minimum required version of MacOS is 10.7.