Elements 13: Requires login, why?

  • 1
  • Question
  • Updated 5 years ago
  • Answered
  • (Edited)
I purchased Adobe Photoshop Elements 13 (Windows,English) for $106.29 and and it has been working great until now? For some reason it want's me to sign in but I don't want to sign in because I DO NOT/WILL NOT USE the cloud, and teat is exactly why I purchased this product..
Photo of Larry Young

Larry Young

  • 5 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15632 Posts
  • 2367 Reply Likes
Official Response
Hi Larry,

It's required for registering your product and validating the software as Adobe Genuine: http://blogs.adobe.com/photoshopdotco...
Photo of Larry Young

Larry Young

  • 5 Posts
  • 0 Reply Likes
Thanks Jeffrey, I appreciate the quick response. Based on same, I understand that each/every time I use this product my computer must be connected to the internet and I must logon, otherwise the product WILL NOT WORK! To be clear, I do not want a product that requires an internet connection each/every time I want to use it.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15622 Posts
  • 2365 Reply Likes
Hi Larry, Elements should not require you to log on each time nor connect to the internet each time the product is launched for use.

You only need internet connectivity if you want to publish your photos online or sync your images to Adobe Revel.

Are you seeing a different behavior?
Photo of Larry Young

Larry Young

  • 5 Posts
  • 0 Reply Likes
Yes, that is what is frustrating.. When i try to launch the program the first screen that comes up states; "Sign In Required - please sign in with your Adobe ID - Terms and conditions for trial software - etc., etc., etc..." Of course, I do not have trial software because my credit card was charged.. My Order Number was AD014283049 and it was dated October 6, 2014.. Have I been been somehow scammed, this is really annoying becasue i do not want to be required to have an internet connection or an active logon every time I use this product... Any assistance to resolve this issue would be most appreciated..
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15622 Posts
  • 2365 Reply Likes
Hi Larry, Did you sign-in at least once to activate and register the product? Or are you trying to skip this step every time? Once you sign-in once, it shouldn't bug you again.
Photo of Larry Young

Larry Young

  • 5 Posts
  • 0 Reply Likes
Yes, I did activate and register my product and it is listed when I view my account????
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15622 Posts
  • 2365 Reply Likes
Ok. And you're still prompted to sign-in and accept terms every single time you launch Elements?
Photo of Larry Young

Larry Young

  • 5 Posts
  • 0 Reply Likes
Hi Jeffrey, Yes, I am even required to provide the serial number of the product, which is a real pain.. I did have some trouble with the initial download/install and had to contact tech support for help, they provided a "special" link to download/install from???? Anyhow, I am going to attach the six (6) screens I am required to go thru each time I want to use the product..
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15632 Posts
  • 2367 Reply Likes
OK. I asked an agent to contact you yesterday. They tried calling the number in your account details but didn't get an answer or voicemail. Sounds like they sent an email to the email address you've used here to set up a call back. Did you get the email? (Might need to check your spam filter). If you have a new number, update in your account and I'll have them try giving your a call back.