Adobe Lightroom Fails to Accurately use GPS Location Data

  • 1
  • Problem
  • Updated 3 years ago
Does Adobe Lightroom have trouble interpreting GPS location data or is it my imagination?

After a week wandering around America's Pacific Northwest, I merged the photos from my Nikon D810 with the location data provided by the smart phone application Geotag Photos. (Very impressed and a heck of a lot less expensive and intrusive than the hardware GPS devices available for my camera.)

Nikon ViewNX 2 correctly interprets the GPS location data: photos taken at the Seattle Space Needle show up on the map at the Seattle Space Needle. When I copy the location data out of the NEF file (47 37.1685N 122 20.9793W) into Google Maps, the correct location is found.

However, when I go into Lightroom CC (2015.3), you map shows my photos having been taken in wildly different locations - often dozens of miles away from where they were actually taken. In fact, there isn't a single photo that is placed in the right location by Lightroom.

Of note, I've tried applying the GPS metadata using both Lightroom and the GeoTag Photos Pro desktop application (http://www.geotagphotos.net/) with no difference in the Lightroom position accuracy.

Am I doing something wrong (which I doubt because Nikon and Google properly place the photo) or is Lightroom broken?

Here is an example of where both Nikon View and Lightroom place my photo...
http://matt.steinhoff.net/adobe/Light...

Here is the GPS track in GPX format...
http://matt.steinhoff.net/adobe/GPS-T...

Here is the original image...
http://matt.steinhoff.net/adobe/MLS_4...
Photo of Matthew Steinhoff

Matthew Steinhoff

  • 1 Post
  • 0 Reply Likes
  • grumpy.

Posted 3 years ago

  • 1
Photo of John R. Ellis

John R. Ellis, Champion

  • 3871 Posts
  • 1023 Reply Likes
When I load your sample photo into my LR CC 2015.3 (OS X 10.10.5), LR's Map module shows the photo in the same spot as Google Maps:

Photo of John R. Ellis

John R. Ellis, Champion

  • 3871 Posts
  • 1023 Reply Likes
Oops, my reply got truncated somehow:

LR is buggy and has problems accurately displaying locations when you paste coordinates into the Map module's search box, but I haven't seen reports of it incorrectly displaying locations of coordinates embedded in photos. So let's try to narrow down what's going on with you.