Adobe Lightroom Doesn't Scale properly in 2-monitor setup with different DPI scalings

  • 1
  • Problem
  • Updated 2 years ago
I had 2 monitors, a 5K DELL (UP2715K), set as primary, and a lower resolution DELL which was my secondary monitor. The 5K monitor uses 200% DPI scaling while the other one 100%. Lightroom is set to enlarged fonts by 200%. Everything worked fine.

Recently, I replaced the secondary monitor with Acer X34 (100% DPI scaling) and had to make it primary due to G-SYNC requirement leaving the 5K as my secondary monitor. In Windows 7, I'm using DPI scaling set 100% for Acer and 200% for Dell 5K. When I open Lightroom, all menu fonts and tooltips are really tiny like it had used 100% scaling instead of 200%.

When I ran SystemInfo, I get the following:

Lightroom version: CC 2015.6 [ 1078672 ]License: Creative Cloud
Operating system: Windows 10
Version: 10.0
Application architecture: x64
System architecture: x64
Logical processor count: 12
Processor speed: 3.5 GHz
Built-in memory: 32669.3 MB
Real memory available to Lightroom: 32669.3 MB
Real memory used by Lightroom: 935.9 MB (2.8%)
Virtual memory used by Lightroom: 911.0 MB
Memory cache size: 559.1 MB
Maximum thread count used by Camera Raw: 12
Camera Raw SIMD optimization: SSE2,AVX,AVX2
System DPI setting: 96 DPI (high DPI mode)
Desktop composition enabled: Yes
Displays: 1) 3440x1440, 2) 5120x2880
Input types: Multitouch: No, Integrated touch: No, Integrated pen: No, External touch: No, External pen: No, Keyboard: No

Graphics Processor Info: 
GeForce GTX 1080/PCIe/SSE2

Check OpenGL support: Passed
Vendor: NVIDIA Corporation
Version: 3.3.0 NVIDIA 368.39
Renderer: GeForce GTX 1080/PCIe/SSE2
LanguageVersion: 3.30 NVIDIA via Cg compiler

------------------------------------

It looks like the DPI scaling recognized by Adobe is 96 (which seems to be coming from the first monitor, not the one the program is running on).

Is there a workaround that would always force high DPI for Lightroom?
Photo of Bracken

Bracken

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1

Be the first to post a reply!