Lightroom Classic: Crashing in Catalina while importing

  • 1
  • Problem
  • Updated 8 months ago
  • (Edited)
Recently, I updated my mac to ios Catalina.  I was not aware of the problems to avoid this update at the time.  Once I updated at the beginning of the month, I tried to import some photos from my Canon 80d directly into lightroom and the software crashed.  Everything would start, as usual, pictures would start to load onto the screen and then...nothing.  The software crashed and closed.  I tried multiple times and the same result.  I did some research and saw that there were currently some compatibility issues, but I am still curious as to why this would cause a crash during the import process from the camera and not iphoto or something else.  If I have imported photos from before Catalina, I can still work on them, edit them, everything just as usual.  I simply can no longer import my photos directly from my Canon 80d into lightroom on my mac. This week Adobe released updates to much of their cloud-based/subscription-based services and so I reluctantly tried importing my photos from the same camera...the problem still exists. Nowhere on Adobe's site do they mention this sort of issue occurring and it is slowing down my business.  I cannot import the photos to properly edit them and get them back to the customers in a timely manner.  Is this issue known? I mean, I have reported it about 20 times, but still, nothing is being done about it, or so it seems. Is there even a patch coming? Has anyone else experienced something similar?
Photo of Dana Burnett

Dana Burnett

  • 1 Post
  • 0 Reply Likes
  • angry/frustrated

Posted 8 months ago

  • 1
Photo of Mayuri Jain

Mayuri Jain, Employee

  • 90 Posts
  • 36 Reply Likes
Hi Dana,

Have you submitted the crash in Adobe crash reporter with your email id? For the time being, please  try to import image from SD card/CF card.

Thanks
Mayuri
Photo of Margaret Kelley

Margaret Kelley

  • 4 Posts
  • 0 Reply Likes
I cannot work on my photos in Lightroom or export them.  Keep getting the message "cannot open the file." Have not tried to import and won't until apple makes some fixes.  I did the first Apple update for Catalina, but not the second.  Did you do the second update? And did you do all the Adobe updates?


Photo of Lorinda Fraboni

Lorinda Fraboni

  • 6 Posts
  • 2 Reply Likes
I am not having any problems. I first load the photographs on my computer then import them into Lightroom cc. I have not had the problems you describe. I have loaded Catalina and every update.
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5650 Posts
  • 2259 Reply Likes
Margaret, go to System Preferences > Security & Privacy > Privacy tab > Files and Folders and make sure that Lightroom has permission to access the desktop and other folders. That's the most likely suspect in your case.
Photo of Richard Hix

Richard Hix

  • 32 Posts
  • 6 Reply Likes
What version of LR are you using.  Last week my wife's Mac quit importing after updating LR to version 9.  She'd been using Catalina for about three weeks with no problem with LR Classic version 8.4.1.  After a couple of hours chatting with adobe tech support, the tech rolled her LR back to 8.4.1, and. everything works again.  I never updated to LR9 and have had not problems with Catalina.  The tech said there were known problem, and Adobe was working on it.  Try going back to 8.4.1 and see if that helps.  Your version 8 lrcat should still be in it's original folder along with the lrcat for version 9. You just have to select the right Lightroom catalog to match the version of LR.