Lightroom Classic: Add to Target Collection B Key Shortcut Toggle Not Working Correctly (Windows)

  • 1
  • Problem
  • Updated 5 months ago
  • (Edited)
Since updating to LR Classic CC 7.2 for PC, toggle seems unaware of initial state. When B is pressed to add a photo to target collection, the confirmation message that comes up is "Removed from Target Collection," and the photo is not added. When B is pressed to remove a photo, the confirmation message is "Added to Target Collection" and the photo is not removed. This happens erratically, and behavior can be fixed by restarting LR. Problem is specific to the February 2018 update.
Photo of Durham1

Durham1

  • 4 Posts
  • 0 Reply Likes

Posted 5 months ago

  • 1
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 4111 Posts
  • 1470 Reply Likes
In the Catalog panel, is there still a + symbol next to Quick Collection when this is happening?
Photo of Durham1

Durham1

  • 4 Posts
  • 0 Reply Likes
Yes
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1414 Posts
  • 435 Reply Likes
Is this consistently reproducible? I am not able to reproduce the issue on my end. 

Could it be possible that you pressed B twice in quick succession and Lr is slow in responding to process the key command?
Photo of Durham1

Durham1

  • 4 Posts
  • 0 Reply Likes
It's inconsistent. As I indicated, merely restarting Lightroom without a machine reboot can fix the problem. Once present, it persists throughout a session until LR is closed. I have not identified other conditions that must obtain to reproduce the issue. If I do, I will post the specifics. Importantly, I have observed this issue several times since updating. It occurred yesterday and then again today right after the machine was first turned on and LR opened. Being certain to press the B key just  once does not require a piano virtuoso. It's not a press twice issue. When file and collection handling was altered in this update, this new bug was introduced.  Thanks.
(Edited)
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1414 Posts
  • 435 Reply Likes
Try pause the Lr mobile sync from Ligtroom's top left identity plate window area, and relaunch Lr. And see if it happens again and report back.
Photo of Durham1

Durham1

  • 4 Posts
  • 0 Reply Likes
Didn't reproduce issue. B key works as expected even after turning off Sync and restarting LR. After using B to add or remove photos, I confirmed that Sync was still set to Pause post LR restart.