Photoshop: Action issues

  • 1
  • Question
  • Updated 5 months ago
  • (Edited)
I have created and action to dlete the background of images based on a clipping path. After recording the action when trying to play it back it changes the delete (image) to dlete (path)
Photo of Dennis Orourke

Dennis Orourke

  • 10 Posts
  • 0 Reply Likes

Posted 5 months ago

  • 1
Photo of David Converse

David Converse

  • 682 Posts
  • 207 Reply Likes
Can you post a screenshot of the recorded action?
Photo of Dennis Orourke

Dennis Orourke

  • 10 Posts
  • 0 Reply Likes
so after tons of frustration and since I need to change about 1600 images to png files with no backgrounds (png files dont include vector clipping paths anyway) I recorded a new action that after i used the path to make the selection i deleted the path then inverted the selection and deleted the background. It worked but WTF. So i went back to this new action and unchecked the select path and delete path steps after the original selection had been created and let it play again so the action would skip those two steps and go right to inverting then deleting... and instead of deleting image it decided to change that last delete step back into "delete path" ***computer getting thrown out window**** HELP!
(Edited)
Photo of Dennis Orourke

Dennis Orourke

  • 10 Posts
  • 0 Reply Likes

Photo of Dennis Orourke

Dennis Orourke

  • 10 Posts
  • 0 Reply Likes
As you can see - the path menu is now empty but there is no Delete path in the action. In this version i did not delete the path when recording either. It does not matter if I include a save in the record as well. I could stop it at deleting the background and same thing happens.
Photo of Dennis Orourke

Dennis Orourke

  • 10 Posts
  • 0 Reply Likes
I understand what is going on - the action is not recording the cursor deselecting the path during recording. When I record it the target image works out fine but the next image does not because of that. What is strage is I had this action for a long time and it worked. I figured this out now by recording one step at a time and playing back.
Photo of Dennis Orourke

Dennis Orourke

  • 10 Posts
  • 0 Reply Likes
Found my workaround - I added two steps. After making path a selection (while recording -which automatically deselects the path but in playback was leaving the path selected) i then had to record selecting the path again and actually deselecting the path in the path pallet so the action shows "deselect path" as a step. then as the selection was still active I could invert it and delete the background rather than the path. UUUUHG! annoying. Must have been the last update.
Photo of Dennis Orourke

Dennis Orourke

  • 10 Posts
  • 0 Reply Likes
I went back and deleted the second "select path" step out and as long as the "deselect path" remained, it all works fine. Thing must be just getting picky in the latest update.
Photo of Dennis Orourke

Dennis Orourke

  • 10 Posts
  • 0 Reply Likes

Photo of Dennis Orourke

Dennis Orourke

  • 10 Posts
  • 0 Reply Likes
As you can see - background gone but path still exists. Now I can use this in the image processor command to do an entire folder and save out as png files
Photo of eartho

eartho, Champion

  • 1090 Posts
  • 330 Reply Likes
another way of doing this is to simply make a vector mask for the layer using the path, then run the processor to save as png.