Lightroom: Abandon 1-letter commands

  • 1
  • Idea
  • Updated 2 years ago
  • (Edited)
Unfortunately LR is one of the applications using single letters as commands. This presents you with all sorts of unexpected behavior. I had several occasions where I was editing text in e.g. the caption box and suddenly LR started to interpret letters as commands. No idea why. Most likely because I hit some key, taking it out of text-editing mode, but if you do not notice this is happening, only a sudden unexpected change of view or screen will alarm you. Because I had been typing several letters before I noticed something unexpected occurred, I had no idea what damage had been done in the meantime.

This problem can simply be solved by not using single letter commands and have commands always be accompanied by Ctrl, Option or Cmd.

Please make this a setting or build it in as a standard.
Photo of Hans Douma

Hans Douma

  • 71 Posts
  • 4 Reply Likes
  • frustrated

Posted 2 years ago

  • 1
Photo of Joe Boxer

Joe Boxer

  • 17 Posts
  • 1 Reply Like
Have a look at this plugin, "KeyBoard Tamer." It's available for MAC and PC. Might help your situation: https://photographers-toolbox.com/blog/category/keyboardtamer/
Photo of J Alley

J Alley

  • 14 Posts
  • 5 Reply Likes
since we work in Photoshop and premiere the shortcuts are great, perhaps instead they can use a lock text command or have that as an option for you.

Alternatively you could change the keyboard and shortcuts in LR to disable all the alphabetical shortcuts.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1414 Posts
  • 435 Reply Likes
What version of Lr and OS? I remember my colleague fix a bug like this recently in Lr CC 2015.5/6.5. The latest version is Lr CC 2015.6.1/6.6.1.
Photo of Rory Hill

Rory Hill

  • 241 Posts
  • 35 Reply Likes
This is a really bad idea.  Unmodified commands are one of the reasons I love Lr and Photoshop.  I agree this can cause confusion when entering text but I would prefer to modify my habits than my shortcuts.  :*)
Photo of Hans Douma

Hans Douma

  • 71 Posts
  • 4 Reply Likes
Rory, this has nothing to do with "changing habits". Quite the opposite, actually. Habits imply an intentional action and the problem I describe has to do with unintentionally doing something causing these commands to be executed. 
Photo of Rory Hill

Rory Hill

  • 241 Posts
  • 35 Reply Likes
I hear you Hans.  That is definitely a problem, but it is a bug and the solution is to fix the bug, not cripple the ergonomics of the rest of the application.  
Photo of Alan Garrett

Alan Garrett

  • 7 Posts
  • 1 Reply Like
I agree that it's a bad idea to have commands ALWAYS accompanied by Ctrl, Option or Cmd. When entering a sizeable amount of text (in LR, or any application that has a tiny text field), I enter it into notepad, and copy into the LR Text box, thus easily removing the problem.
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1414 Posts
  • 435 Reply Likes
Please update to the latest Lr CC 2015.6.1/6.6.1 to see if you still experience the problem.