Photoshop Elements: lots of crashes, and version 7 won't work

  • 1
  • Problem
  • Updated 7 years ago
  • (Edited)
I bought Elements 7 a few years back. Loved it. Recently tried to test Elements 10, Lightroom, and CS5. all crashed multiple times. Now E7 doesn't work. Thanks a lot Adobe. Should have flushed the money instead.
Photo of David Smitley

David Smitley

  • 3 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 822 Reply Likes
Well, what about your system is different and might be causing crashes that other users aren't seeing?

And what do you mean by "E7 doesn't work"?

What OS version are you using?

Are there any printer or video drivers on your system that haven't been updated in a while?

Have you installed any third party plugins or scanner drivers?

Have you added any font files that might be corrupt?
Photo of David Smitley

David Smitley

  • 3 Posts
  • 0 Reply Likes
Nothing is diff. I run Windows 7, no printers or scanners, video is up-to-date. No plug ins or fonts.

E7 Worked fine until I tried E10, then E7 started crashing on program start-up along w/ E10. I uninstalled a re-installed E7 around 10x. The problem persisted. I then dl'ed Lightroom and CS5. Start-up crashes. I was quite taken w/ Lightroom, but... I have good av protection. Windows 7 is up-to-date. Again, it all started w/ E10. Now I have no photo finesser. I am at a loss.
Photo of David Smitley

David Smitley

  • 3 Posts
  • 0 Reply Likes
Response #2, because resonse #1 was not answered:

My system is the same except for installing E10, which then made E7 continuously crash. Elements is the only program that crashes on my system. E7 worked perfectly until I installed E10. I uninstalled E7 and E10, and then tried to re-install E7 several times with no success. I paid $100 for E7, and it is now useless.

I'm using Windows7 as my OS, my printer and video drivers are up-to-date, and I have loaded no 3rd party plugins, scanner drivers, nor font files. I would really like my E7 back.
Photo of Brett N

Brett N, Official Rep

  • 2258 Posts
  • 115 Reply Likes
Are you getting any error messages?

You are getting a crash when launching Photoshop Elements 7, Elements 10, Lightroom 3, and Photoshop CS5? Sounds like a more serious issue is at hand. Each of these programs is very different and none of them share the same files (not even PSE7 and PSE10, they are completely individual and independent installations). Multiple uninstalls and reinstalls are not likely to fix anything, especially if you don't change the environment each time, each install will be the same as the last.

Have you tried working in a new user account?

Have you tried disabling background processes? Disable startup items, services | Windows
Photo of MDV

MDV

  • 31 Posts
  • 2 Reply Likes
Some Adobe's programs are demanding and crashes usually happen when there is a combination of 'unstable' windows system and many updates to do.

For updates I mean Windows [at least] critical updates and possibly SP1 and 'hardware' drivers updates.

Hardware drivers updates seems to be causing problems with Windows 7 updated to SP1. Sometimes SP1 do not even install as it finds problems.

Have you had problems installing SP1 [service pack 1]? i.e. failed a few times?

If so, you need to first update your hardware drivers: Motherboard Chipset, External devices, Graphics Cards [nVidia especially has problems!] , then install SP1.

If you still have problems, visit Microsoft website support, as they give FREE support for problems 'Windows' updates.

Then install all your programs - one at the time and reboot each time you install one and 'let' the installers do their job - also - shut-down ant Anti-virus and Firewall when installing [ disconnect from the internet first! Then re-connect after you finished and re-started AV and Firewall, to probably get Adobe's updates.

I hope this helps you out.
M

PS I do not work for anybody, I am only a user trying to help [for free], please be nice!