LIGHTROOM 5.3: "Xmp:Hierarchical Subject" metadata crashes importer

  • 1
  • Problem
  • Updated 5 years ago
  • (Edited)
Everytime Lightroom (5.3 on Windows 7 64bit) tries to import pictures with certain metadata, it crashes. I tired to import about 10.000 pictures and as soon as the import algorithm got to such a picture, it stopped without any feedback.
In my case "Xmp:Hierarchical Subject" was set to "Facebook*" (metadata was written by Digikam) and produced the crash. After I remove this metadata using ExifTool, there were no more errors.
Photo of T W

T W

  • 4 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of David Franzen

David Franzen, Employee

  • 99 Posts
  • 20 Reply Likes
Hi TW,

Can you please post an example of a file with this metadata to download?

Thanks,
David
Photo of T W

T W

  • 4 Posts
  • 0 Reply Likes
Hi David,
here you can find an example http://www.file-upload.net/download-8668329/example.jpg.html. I hope it will work.

Regards,
TW
Photo of David Franzen

David Franzen, Employee

  • 99 Posts
  • 20 Reply Likes
Thanks TW!

I think I've reproduced your problem, however, instead of crashing, Lightroom appears to get stuck on your example.jpg file. I'm able to cancel the import task and continue to use Lightroom. Getting stuck looks like a problem, but I want to make sure we're seeing the same problem.

Thanks,
David
Photo of T W

T W

  • 4 Posts
  • 0 Reply Likes
Hi David,
sorry for this misleading description of the problem, I meant the same behavior like you, that the import algorithm get stuck on the file.
Still sometimes I couldn't just cancel the import task, because the import button was still disabled.So I had to restart Lightroom before I could start another import.
As I wrote before, deleting the metadata "Xmp:Hierarchical Subject" using Exiv2 or ExifTool solved the problem. So it seems that the importer cannot handle the content of this metadata.

Bye,
TW
Photo of Phil Harvey

Phil Harvey

  • 11 Posts
  • 0 Reply Likes
The XMP is not formatted properly. The contact information should be inside a CreatorContractInfo structure, but it is not. Also, there is an empty element in the HierarchicalSubject list. I'm guessing that this is confusing LR.

- Phil
Photo of T W

T W

  • 4 Posts
  • 0 Reply Likes
I tried to delete the author/contact information from the example picture, maybe that's why the structure is formatted improperly. Nevertheless the "Hierarchical Subject" seems to be invalid, because deleting it solves the problem for Lightroom.
In either way Lightroom should report such an error instead of getting stuck..

TW