Photoshop: "Save for Web" error when "My Documents" network path is disconnected

  • 4
  • Problem
  • Updated 3 weeks ago
  • Solved
  • (Edited)
On my PC, "My Documents" is mapped to a network drive. Whenever the network drive is disconnected, Photoshop throws an error when trying to bring up the "Save for web" dialog box. The error is: "The operation could not be completed. The system cannot find the path specified." When I click OK on this error message popup, the popup goes away and nothing else happens. The "Save for web" dialog is not accessible.

This is especially a problem when I travel with my PC and need to use Photoshop on the road, since I cannot connect to my network drive for My Documents. I understand that the system cannot find the path specified, but it shouldn't bail on the "Save for web" dialog because of it. Use a different default path. I'm not sure why it's looking for that path anyway, since it happens even when my last saved file isn't in "My Documents".
Photo of TODD GILLISSIE

TODD GILLISSIE

  • 3 Posts
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 4
Photo of Ping

Ping, Employee

  • 28 Posts
  • 4 Reply Likes
Could you please provide your OS, Server type? I try to map my document to network drive on XP and S4W pop up error message after I click Save button.
Photo of TODD GILLISSIE

TODD GILLISSIE

  • 3 Posts
  • 0 Reply Likes
Vista. I don't think Server type applies. It's just a drive mapping to a network share on another PC.
Photo of TODD GILLISSIE

TODD GILLISSIE

  • 3 Posts
  • 0 Reply Likes
Maybe I should mention, the PC with the network share is Windows 7.
Photo of Ping

Ping, Employee

  • 28 Posts
  • 4 Reply Likes
Hi I can reproduce this problem on Vista, you are right, it is have no relationship with server type. It is a vista only bug. Will report a bug, thanks for your report.
Photo of Jenne Smith

Jenne Smith

  • 1 Post
  • 0 Reply Likes
I am having the same issue and cannot complete an assignment for school. Ping, have you identified the steps to correct this? I am running Windows XP and am on a network as well.
Photo of Sergei Chepa

Sergei Chepa

  • 1 Post
  • 6 Reply Likes
Had same problem and found the foolowing solution. All you need to edit registry entry:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

The entry for "Personal" was set to an external that was not connected so you can set it to a location on HD (e.g. %USERPROFILE%\Documents or any other)
Photo of Prince Ibrahim Adewale Olawuyi

Prince Ibrahim Adewale Olawuyi

  • 1 Post
  • 1 Reply Like
Had same problem and found the foolowing solution. All you need to edit registry entry:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

The entry for "Personal" was set to an external that was not connected so you can set it to a location on HD (e.g. %USERPROFILE%\Documents or any other)


This worked for me
Photo of Michael Glassman

Michael Glassman

  • 1 Post
  • 0 Reply Likes
This solution worked for me, as well. I had re-located the My Documents folder while setting up a new computer, and the "Personal" registry entry did not get updated. I was having problems when launching Photoshop CC 2017 as well as when using the Export As and Generator functions. All three resolved with this fix. Thank you, Sergei, for posting this solution!
Photo of Sina Enayati

Sina Enayati

  • 1 Post
  • 0 Reply Likes
This solved my problem. Thanks! 
Photo of Mmayur Oza

Mmayur Oza

  • 1 Post
  • 0 Reply Likes
Thanks Sergei Chepa,

This helps a lot. and is works. 
Photo of Kreative Fold

Kreative Fold

  • 1 Post
  • 0 Reply Likes
Great it works Thankyou!
Photo of Cheri Schappaugh

Cheri Schappaugh

  • 2 Posts
  • 0 Reply Likes
I am having the same issue in adobe CC
Photo of Cheri Schappaugh

Cheri Schappaugh

  • 2 Posts
  • 0 Reply Likes
My registery does say %USERPROFILE%
Photo of neville carpenter

neville carpenter

  • 1 Post
  • 1 Reply Like
This works for me, The registry entry was pointing to the old profile path. Put in the new profile path and is works fine.

Thanks.
Photo of Demetrio García

Demetrio García

  • 1 Post
  • 0 Reply Likes
This worked for me too. Thanks so much. 
Photo of Luis Ameglio Diaz

Luis Ameglio Diaz

  • 1 Post
  • 1 Reply Like
or just go to documents right click properties > Location > Restore Default...

Apply it to any folder that needs to.
Photo of Kevin Smith

Kevin Smith

  • 1 Post
  • 0 Reply Likes
Is there no solution for this problem at this point? I am running Vista for my OS. Any help on this matter would be appreciated, thanks!
Photo of Lyndsey Weedop

Lyndsey Weedop

  • 2 Posts
  • 0 Reply Likes
I was having the same trouble and ended up discovering that my file name was too long to save to the server I'm using.

If you're trying to save remotely, try saving locally and see if that works. If so, it may be due to the file name length.