Photoshop: "Save As" truncates file name

  • 3
  • Problem
  • Updated 7 months ago
  • Solved
  • (Edited)
Any time i have work on a file with a pretty long file name (~10 words) and try to "save as" it cuts the end of the file name and extension. so i need to write it manually each time i save a file.

for example:
Freedom Tower, Battery Park, 8.11.11 010-2lit
becoming:
Freedom Tower, Battery Park, 8.11.jpg

and sometimes it removes the JPG... dont know why. and then the file becomes unreadable - the computer cant recognize it as a picture until i rename the file and add JPG.

Its on Windows 7 and CS5
Photo of Noam Galai

Noam Galai

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 7 years ago

  • 3
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
The file extension on the original file is "11 010-2lit", that file extension was removed and "jpg" added.
Photo of Noam Galai

Noam Galai

  • 4 Posts
  • 0 Reply Likes
For the past 7 years I saved all my files in this format and had no issues. it never made any change to the name when saving. only now when i got a new computer and upgraded from CS4 to CS5...

There must be a solution for it... i cant believe Adobe will just leave this bug unsolved.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14146 Posts
  • 1765 Reply Likes
Note, you upgraded your OS. The OS has more to do with this than Photoshop.
Photo of Noam Galai

Noam Galai

  • 4 Posts
  • 0 Reply Likes
So it means Photoshop CS5 is not built to use Windows 7? any way i can change something to make this issue go away?
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14146 Posts
  • 1765 Reply Likes
No, it means that the OS controls the conventions on how file extensions are file names are handled.
Photo of Noam Galai

Noam Galai

  • 4 Posts
  • 0 Reply Likes
oh ok.. but its not explaining why my file names are being cut in photoshop :(
Photo of Stephen Kaiser

Stephen Kaiser

  • 1 Post
  • 0 Reply Likes
Why is this marked solved? This isn't solved. This has been broken for years.

Open a PDF named "MyFile 11.20.2010.pdf"
File > Save As... > PNG
You get "MyFile 11.png"

I am a web, desktop, and mobile programmer. This is a bug. This is broken. Periods are valid characters in Windows file names. Truncating the filename at the first instance of a period is silly. The file extension only consists of the characters following the LAST period. If you don't believe me then view the above mentioned file in a folder that is set to hide file extensions. ".pdf" will disappear, leaving "MyFile 11.20.2010" visible. Please fix this.
Photo of nbnbn nbnbnnbnb

nbnbn nbnbnnbnb

  • 4 Posts
  • 0 Reply Likes
Correct. This isn't fixed and it's a BUG.

It is extremely annoying and makes batch-saving files with dots in them impossible. Photoshop is the only application I have ever used or seen where this happens. This is not a feature and not determined by the OS and it has not been this way in former versions.

Please fix it.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14147 Posts
  • 1765 Reply Likes
What version of Photoshop are you using?
Photo of Ivan Romero_Fornes

Ivan Romero_Fornes

  • 1 Post
  • 0 Reply Likes
IF the name of the original file is too long, this would happen all the time.
It happened to me and this was the solution that I found.

Hope this helps.
=)
Photo of Jacob Carrell

Jacob Carrell

  • 1 Post
  • 0 Reply Likes

This applies specifically to Adobe Acrobat Professional DC, but I expect this to apply to all products experiencing issues where the file name is cut off after the first period.

The solution to this is actually a windows explorer setting. Open up My Computer (or any Windows Explorer window) and hit alt to bring up the options menu. -> Tools -> Folder Options -> (Tab) View -> Uncheck "Hide Extensions for known file types" And, Done!

Edit: SEO Optimization

(Edited)
Photo of Hazel Joy Pekas-Figueroa

Hazel Joy Pekas-Figueroa

  • 1 Post
  • 0 Reply Likes
This worked for me.  thank you so much!!!