Photoshop: How do I set [open with] to Photoshop or set it as a [standard program]? (Windows 7)

  • 2
  • Question
  • Updated 4 years ago
  • Answered
  • (Edited)
How can I fix that I cannot [open with] Photoshop or set it as a [standard program]?
It won't let me choose Photohop.exe ... No, reinstall didn't succeed :(
I'm here on a Win7/64 machine ...
Photo of Bug tigrao

Bug tigrao

  • 1 Post
  • 0 Reply Likes

Posted 5 years ago

  • 2
Photo of David Dobish

David Dobish, Senior QE Photoshop

  • 174 Posts
  • 30 Reply Likes
1. Right Click on image
2. Look for Open Wtih...
3. Choose "Choose Default Program..."
4. Click Browse in dialog
5. Find PS
6. Choose it
7. Make sure "Always use the selected program to open this kind of file" check box is checked.

If this does not work then something may be wrong with your OS.
Photo of PSE Fan

PSE Fan

  • 3 Posts
  • 0 Reply Likes
PSE 10 does not show as a default selection when using "open with" to open jpegs etc. I had no such problem with PSE 6 or 9. I followed a forum suggestion to browse and select PSE 10 from the Organiser folder. This works now but only if PSE 10 is already running. I can then right click and "open with" from my Pictures or other folders folder and all's ok. Would you please look into this and fix if at all possible please? It's a major irritant and I'm sure something must be able to be done about this as it probably affecting all users who open from directly from their folders and files rather than from within PSE 10.

This reply was created from a merged topic originally titled
PSE 10 does not show as a default when right clicking images in folders to "open with".
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Chief Customer Advocate

  • 10756 Posts
  • 807 Reply Likes
Try David's solution above. Let us know if that doesn't work for you.
Photo of PSE Fan

PSE Fan

  • 3 Posts
  • 0 Reply Likes
Thank you for your prompt response, really appreciate it. David's solution is the usual way of doing things but unfortunately doesn't work. Intead one has to browse and select PSE10 from the Organiser folder rather than the Programs folder. It seems from the forum and Google searches, that others have experienced, and continue to experience the same problem. I run Windows Vista Home Premium but I notice that folks with Windows 7 seem to have the same issue so I'm not convinced that it points to an operating system problem.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Chief Customer Advocate

  • 10756 Posts
  • 807 Reply Likes
Hmm. That doesn't make any sense at all. You should be selecting the Editor from the Programs folder to set it as the default. You're doing all this from the Windows Explorer, correct?
Photo of PSE Fan

PSE Fan

  • 3 Posts
  • 0 Reply Likes
Yes, correct, from explorer.
When purchased, my PSE 10 files downloaded automatically as follows. Program Files - Adobe - Photoshop Elements 10. Important to note that there are no exe files within this Photoshop 10 folder, not PSE 10 nor PSE Editor.
Both however are found in the Organiser folder which is also placed directly under the Adobe main folder.
This is where it gets interesting.
1. Right clicking/browsing to set as default only works with PSE10.exe (found and selected from within Organisers folder) but when I do the same for the Editor exe file, it won't take.

2. I tried copying both exe files to the Adobe - PSE 10 folder but the Editor exe file still won't take.

3. Having successfully set PSE 10.exe as an option, I can now open jpegs etc directly from the windows explorer picture files, but only if PSE 10 has already been opened.
In other words, opening the jpegs doesn't automatically open PSE10. Although now that I'm aware of this, it's not so much of a problem as before.
So my observation as follows.

That when Adobe constructs the folders and their contents, that they place the exe files within the PSE 10 folder and not the Organiser folder.
Not sure but hoping this may somehow work even though as I mentioned above, I tried copying the editor exe file to the PSE 10 folder but it still didn't work.
Hoping my observations go some way to resolving this issue. Many thanks. Ken Gardner.
Photo of Jean Farrell

Jean Farrell

  • 2 Posts
  • 1 Reply Like
I had exactly the same problem. But thanks to this post - I selected Photoshop Elements 10 as the default from with the Organiser file in Adobe programmes and that has worked brilliantly. It doesn't matter whether PSE is open or not - so problem fully resolved. Thanks
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Chief Customer Advocate

  • 10756 Posts
  • 807 Reply Likes
Great. Glad you found your solution. Thanks for letting us know.