LIGHTROOM: "Discard all 1:1 Previews" Does Not Work

  • 2
  • Problem
  • Updated 4 years ago
  • (Edited)
In Lightroom, "Discard all 1:1 Previews" does not work. I have done this and still have 8GB of preview data in "...Previews.lrdata" folder. I am running LR 5.6 on Win7 x64. I would like to know how to get rid of these previews that are using up valuable space on my SSD.
Photo of Winston Davidian

Winston Davidian

  • 5 Posts
  • 1 Reply Like

Posted 4 years ago

  • 2
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 379 Reply Likes
Yeah - Adobe had this fixed for a while, then broke it again..

Until fixed again, if previews getting too big, just delete the whole catalog Previews.lrdata folder (exit Lightroom first) and start over (rebuild standard previews).

Another option is to relocate previews to a drive with more free space, if you have one..

Or perhaps a better solution: just set the automatic discard policy to "After One Day", assuming you can make it through the day..

Also, consider backing down your preview quality and/or standard preview size to save space.

(see Catalog Settings..).
Photo of Winston Davidian

Winston Davidian

  • 5 Posts
  • 1 Reply Like
Even setting to "after one day" does not seem to get rid of them. Glad to hear it is not just me seeing this. I may delete the previews folder if I really get strapped for space.
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 379 Reply Likes
Oh - bummer. I never actually checked it. To be clear: you may need to restart Lightroom after that day has elapsed, since previews are discarded upon startup, not whilst using..
Photo of Winston Davidian

Winston Davidian

  • 5 Posts
  • 1 Reply Like
I think I have done that, but I'll check again.
Photo of Rob Cole

Rob Cole

  • 4831 Posts
  • 379 Reply Likes
Update: if you can't delete 1:1 previews, try reducing standard preview size a notch.

Reason is complicated and technical, but such will probably work for you - worked for me anyway..