Photoshop 14.1: "Could not save "name of file.psd" because of a program error

  • 1
  • Problem
  • Updated 5 years ago
  • (Edited)
Received dialog "Could not save "SYLVA_027-Edit.psd" because of a program error" when attempting to save a large 8bit psd file this morning. The image is 6732 by 8984 pixels and contains a single embedded raw smart object layer and is 613 mb saved to disk. I am running Photoshop CC version 14.1.1 x64 on a Mac Pro 1,1 running Mac OS X Version 10.7.5 with 6 GB RAM. Tried various fixes & the one that solved my problem was to turn off 2 px feathering of a layer mask attached to a curves layer. When I created a small 8x10 psd file, added a curves layer and gave it a 2 px feather I was able to save the file without the error.

Tim Boole
timboole@mac.com
Photo of Tim Boole

Tim Boole

  • 4 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Can you post the last few lines of the file PSErrorLog.txt from your Photoshop preferences folder?
Photo of Tim Boole

Tim Boole

  • 4 Posts
  • 0 Reply Likes
Chris Cox, an employee of Photoshop Family, replied to Photoshop 14.1: "Could not save "name of file.psd" because of a program error, a problem about Photoshop Family.

Can you post the last few lines of the file PSErrorLog.txt from your Photoshop preferences folder?

Sure:

2013:09:15 23:40:00 : tracked key 0000000000000128 of type P5_ADsc not found : 1 : REQUIRE failed
2013:09:15 23:40:00 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20130910.r.415/photoshop/main/photoshop/xcode/../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed
2013:09:16 00:24:04 : tracked key 0000000000000128 of type P5_ADsc not found : 1 : REQUIRE failed
2013:09:16 00:24:04 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20130910.r.415/photoshop/main/photoshop/xcode/../interfaces/UTrackResourceImp.h : 137 : REQUIRE failed
2013:09:16 06:02:58 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20130910.r.415/photoshop/main/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed
2013:09:16 06:11:15 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20130910.r.415/photoshop/main/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed
2013:09:16 06:11:23 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20130910.r.415/photoshop/main/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed
2013:09:16 06:11:43 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20130910.r.415/photoshop/main/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed
2013:09:16 06:12:01 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20130910.r.415/photoshop/main/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed
2013:09:16 06:12:58 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20130910.r.415/photoshop/main/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed
2013:09:16 06:13:09 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20130910.r.415/photoshop/main/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed
2013:09:16 06:13:29 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20130910.r.415/photoshop/main/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed
2013:09:16 06:15:45 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20130910.r.415/photoshop/main/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed
2013:09:16 06:18:17 : /Volumes/workarea/PS_14_Mac_Daily_Retail/20130910.r.415/photoshop/main/photoshop/xcode/../sources/UVMAccess.cpp : 778 : REQUIRE failed
Photo of Tim Boole

Tim Boole

  • 4 Posts
  • 0 Reply Likes
Also, here's a screen shot of the dialog box:
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Hmmm, that error is due to code we added to prevent crashes that we couldn't explain.

Could you email a copy of that file (or share via dropbox, etc.) to ccox (at) adobe (dot) com ? We'd really like to know exactly what is triggering that error.
Photo of Tim Boole

Tim Boole

  • 4 Posts
  • 0 Reply Likes
Chris, here's the WeTransfer link for that file:
http://we.tl/S2lrf4dcSv
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
I downloaded the file, but so far haven't reproduced the program error in 14.1.1.
Photo of Sef

Sef

  • 34 Posts
  • 3 Reply Likes
Tim - can you first try selecting all, and cropping your image, then save? If that doesnt work, try rasterizing your smart objects, then doing the same and see if that works, just as a test.
Photo of Rodolfo Mello

Rodolfo Mello

  • 3 Posts
  • 0 Reply Likes
Photo of Rodolfo Mello

Rodolfo Mello

  • 3 Posts
  • 0 Reply Likes
after it, the image not save more, its program error
Photo of Rodolfo Mello

Rodolfo Mello

  • 3 Posts
  • 0 Reply Likes
Im delete this layer and the image come back normal....
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 14049 Posts
  • 1735 Reply Likes
If you simply turn off the layer visibility, instead of deleting, will the file save?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 812 Reply Likes
Also, which version are you using, and have you installed all the updates?