"Could not complete your request because of a program error" message when opening program

  • 1
  • Question
  • Updated 3 years ago
I keep getting the error message "could not complete your request because of a program error". This happens everytime I open the program and when trying to use the text tool. I am running PS 12.1 x64 on an iMac running OS 10.7.5. I use suitcase and have scanned my fonts as well as fonts loaded into Font Book and eliminated an trouble makers. HELP!
Photo of Debbie Johnson

Debbie Johnson

  • 4 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 1
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Howdy Debbie,

Have you checked out this document: http://helpx.adobe.com/photoshop/kb/t... ? If you have and you're still having problems, I would also try to trash my preferences on launch. Beyond that, ping me back, and I'll see if I can figure out what's going on.

Thanks,
David
Photo of Deh André

Deh André

  • 2 Posts
  • 0 Reply Likes
worked for me 

I found the solution for me on MAC CS5: Preferences > Type > ̈Font Preview Size ̈ Deselect it (turn off), thanks me later :)
Photo of Debbie Johnson

Debbie Johnson

  • 4 Posts
  • 0 Reply Likes
Hi David
Thanks for sending over those troubleshooting tips. I can't seem to find an answer still though. Here are the results of the solutions..
Solution #1: I updated the Camera Raw 6.7. Still no fix
Solution #2: Didn't work
Solution #3: I couldn't find any of these fonts on my computer. I searched for them by file name.
Solution #4: I validated my fonts. There were 4 that had issues but when I delete them they don't go away. ???
Solution #5: I ran the script with scary results. It says I have 397 fonts installed and all of them failed. How can that be? I haven't been having any other issues. Should I look into a third party fonts diagnotic program? Font Doctor perhaps?
Solution #6: Didn't work
Solution #7: Messing with the terminal makes me have a panic attack.
Solution #8: I have fonts in more than one folder. I have hundreds of fonts and therefore why I use Suitcase. I have always had an outside font folder and not just the one in the Library. Isn't that one just for system fonts?
There you have it. My mess in a nutshell. Any advice.
Thanks in advance.
Debbie
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
Howdy Debbie,

Well, it sounds like you're actually stuck on Solution #4. I'm not sure why they don't go away when you delete them, but if the script locates and identifies four fonts as bad, then until you can truly get them off your system (or at least definitively out of your font cache), then any problem they trigger will persist indefinitely. So, if I were you, that would be the first place to start. Delete or move the offenders and then RETEST #4 to make sure that the OS agrees that they're gone. Solution #5 could quite easily give you negative results because of just one really bad font... For what it's worth, I would do Solution #6 immediately after #4 and #5, assuming the offending fonts were gone. What you describe is starting to sound like a corrupt font cache (Solution #6) which is caused by a system-wide font problem (Solution #5) which is in turn caused by four particularly bad fonts that won't go away (Solution #4).

Does that make sense?

Thanks,
David

p.s. -- you have have fonts ALL over the place, so it's good to manage them and know if you have extraneous copies (which could be triggering problems).

p.s.s. -- given the pervasiveness of your problem, if #4, #5, and #6 don't fix things, you actually need to do #7. Scary, true, but if your OS is having a problem, all the Photoshop fixes in the world won't fix much...8-(
Photo of Debbie Johnson

Debbie Johnson

  • 4 Posts
  • 0 Reply Likes
Thanks again David.
It does make sense. Time-consuming but sensible. :) Sounds like an after work project.
I'll keep you posted.
I appreciate the guidance.
Debbie
Photo of Debbie Johnson

Debbie Johnson

  • 4 Posts
  • 0 Reply Likes
Hi David,
I thought you'd get a kick out of the "end of the story"
It is the typical answer. I'm not sure what I did but it is fixed. I went through all the solutions again. I was working on Solution #8 and moved half my font out and low and behold it worked. I went through the rest of the steps and ended up putting all the fonts back into the folder and it is still fixed.
I think it is a Christmas miracle. Steve Jobs' angel came and visited my Mac perhaps.
Thanks again for you patience in helping me out today.
Debbie
Photo of David

David, Official Rep

  • 2800 Posts
  • 387 Reply Likes
I'm glad it all worked out, Debbie.

If the gremlins come back, you know where to find me...8-)
Photo of Deh André

Deh André

  • 2 Posts
  • 0 Reply Likes
I found the solution for me on MAC CS5: Preferences > Type > ̈Font Preview Size ̈ Deselect it (turn off), thanks me later :)