Photoshop: Repeat of “Could not save because of a program error.“

  • 2
  • Problem
  • Updated 8 months ago
  • Solved
  • (Edited)
Hi,

Something is driving me NUTS! I know I am not the only one who received a dialog box which says, "Could not save because of a program error." Having said that, this problem has been talked about on Google by different people.

It happens when using PS CS5. Then, it has been getting worse in CS6 now. I am not using any servers. I have 12 GB of RAM, and 1 TB HD. iMac i7.

For some reason, when I save a PSD file to an external disk and/or to a compact flash disk (camera disk), it saves fine. Then, I must quit Photoshop and reopen it in order to save that file to my HD.

What is going on??? Please advise.
Photo of Leigh-Anne Tompkins

Leigh-Anne Tompkins

  • 14 Posts
  • 2 Reply Likes
  • Frustrated

Posted 5 years ago

  • 2
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
We have seen this caused by third party plugins (especially buggy font management plugins), and some OS bugs (mostly involving file servers).
Photo of Leigh-Anne Tompkins

Leigh-Anne Tompkins

  • 14 Posts
  • 2 Reply Likes
Thought so, but I can’t figure it on which ones.

I have:
Google Drive
Cubby
Dropbox
LogMeIn (I suspected this, but it not)
Font Agent Pro

I may need to check TypeDNA.

Driving me nuts!
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 764 Reply Likes
LogMeIn has caused problems for other users.
Font Agent Pro has caused problems in the past.

Google Drive and Dropbox don't cause any known issues (I run them myself).

Cubby I don't know.

But are you using any third party plugins outside of the Font Agent Pro plugin?
Photo of Leigh-Anne Tompkins

Leigh-Anne Tompkins

  • 14 Posts
  • 2 Reply Likes
Maybe, TypeDNA... I’ll check.
Photo of Leigh-Anne Tompkins

Leigh-Anne Tompkins

  • 14 Posts
  • 2 Reply Likes
I think the TypeDNA extension is the culprit. Also, I remember now that I added it after I was using the CS 5 for awhile. I have never had this problem before when I was working on CS5. Thanks again!

Leigh-Anne
Photo of Leigh-Anne Whatchamacallit

Leigh-Anne Whatchamacallit

  • 2 Posts
  • 1 Reply Like
LogMeIn software is the culprit that causes the saving error in Photoshop. TypeDNA is NOT the culprit.
Photo of Leigh-Anne Whatchamacallit

Leigh-Anne Whatchamacallit

  • 2 Posts
  • 1 Reply Like
OK, maybe, I’ll write to LogMeIn developers. :-)
Photo of Christopher Gill

Christopher Gill

  • 0 Posts
  • 0 Reply Likes
I'm getting the same problem with CS6 (and, as it happens with InCopy CS5) when saving to my main hard drive. But I am not using LogMeIn software. I can save to external drives, which seems bizarre to me. I am running lots of utility/accessory stuff:
TextExpander
Dropbox
Xmarks
DefaultFolderX
MenuEverywhere
PinPoint
TotalFinder
Yoink
Liquid
Moom
ClipMenu
I know, I know: disable them all and then re-introduce them one at a time. But I have only the one lifetime available.

Chris
Photo of Leigh-Anne Tompkins

Leigh-Anne Tompkins

  • 14 Posts
  • 2 Reply Likes
Okay, try working Photoshop in a new account first. If that works, then it's one of those third party extensions.

It's definitely not TextExpander, DropBox, MenuEverywhere because I have them and they are NOT culprit.

Which ones act like "server"?

Also, try disable the third party plug-ins in Photoshop if you have them. Hold down Shift during startup to disable Optional and 3rd party.
Photo of Leigh-Anne Tompkins

Leigh-Anne Tompkins

  • 14 Posts
  • 2 Reply Likes
I don't know why, but I suspect you using the DefaultFolderX is the culprit.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 764 Reply Likes
Hmm, DefaultFolderX caused some problems a few years ago, but I thought it had been fixed...
Photo of Christopher Gill

Christopher Gill

  • 0 Posts
  • 0 Reply Likes
Thanks Leigh-Anne

Right now I am saving successfully having disabled:

TextExpander
DefaultFolderX
MenuEverywhere
TotalFinder
Liquid

I have a lot of PS work to do today so I'll stick with this for now and experiment further later in the day.

I should have said earlier ... I have been using PS successfully for a month with ALL of these programs running. The problem has popped up occasionally, but only today has it become serious. Before posting here I repaired permissions.

Anyway, for now, I'm back in business. Thanks again for your suggestions.

Chris
Photo of Leigh-Anne Tompkins

Leigh-Anne Tompkins

  • 14 Posts
  • 2 Reply Likes
Okay, I know what you mean. I had this problem regarding not being consistent to figuring out what is causing it.

When you find the "consistent problem," please come back again and tell us.

Thanks again!
Photo of Lisa Hainline

Lisa Hainline

  • 5 Posts
  • 0 Reply Likes
i have this issue also but have NONE of the "culprits" mentioned. now what?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 764 Reply Likes
Details of your system would be a good start:

what OS version?
What Photoshop version?

What troubleshooting have you done?
Have you tried disabling all third party plugins?
Have you tried closing all other applications?
What system utilities do you have installed?
Photo of Lisa Hainline

Lisa Hainline

  • 5 Posts
  • 0 Reply Likes
i have windows 7, photoshop cs5 extended version 12.1 x 64
no plugins ( other than Camera Raw, Compuserve gif, Embed watermark, filter gallery, Open EXR and Read Watermark) so no third party plugins, just what came with this.

system utilities?

All i ever do is work in photoshop and save to a pdf 1xa. i flatten the file and this started happening so it can't be a text / font issue.

I have reinstalled photoshop (but did not uninstall it first) and i really didn't want to delete my color settings for preferences, not sure if thats what gets deleted when you delete preferences as some have said.

ideas? (thanks SO MUCH!)
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 813 Reply Likes
Does this happen with other file formats?

What does the PSErrorLog.txt file say? (in your Photoshop preferences folder)
Photo of Lisa Hainline

Lisa Hainline

  • 5 Posts
  • 0 Reply Likes
no, i can make a jpeg, but not make a pdf even from a black and white file. I'm sorry but i just don't know how to get to the preferences. i have color files for certain printers that i didn't want to loose and not sure how to get around anything else. I can't find any preferences folder on my computer or in the adobe file for photoshop. ?
Photo of Martin Orpen

Martin Orpen

  • 1 Post
  • 0 Reply Likes
I'm getting this error regularly now on Mac OS 10.8.5 with CS6 Photoshop -- 3 times this evening already with different files :-(

The problem seems to be with specific layers that have layer masks.

If I turn the layers off one-by-one then I can usually isolate the problematic layer and simply switch it off.

The file will then save OK!

I open the same file on another Mac running 10.6, switch the problem layer back on and save the file out without any issues.

I really doubt that this is some kind of server error. I'm not using any extensions or plugins on these files either -- they're just simple PSDs with about 5 layers.

The interesting thing that I've noticed is that this problem usually occurs for us when we use layers with masks that are almost mirror images of each other -- one isolating a foreground object and another above it isolating only the background immediately above it.

It'd be useful if there were some way of getting PS to dump data to a log that made sense as all I can see is:

2013:10:02 23:53:04 : /Volumes/workarea/PS_13.1_Mac_Daily_Retail/20130521.r.44/photoshop/main/photoshop/xcode/../sources/UVMAccess.cpp : 783 : REQUIRE failed
2013:10:02 23:53:33 : /Volumes/workarea/PS_13.1_Mac_Daily_Retail/20130521.r.44/photoshop/main/photoshop/xcode/../sources/UVMAccess.cpp : 783 : REQUIRE failed
2013:10:02 23:55:10 : /Volumes/workarea/PS_13.1_Mac_Daily_Retail/20130521.r.44/photoshop/main/photoshop/xcode/../sources/UVMAccess.cpp : 783 : REQUIRE failed
2013:10:02 23:55:43 : /Volumes/workarea/PS_13.1_Mac_Daily_Retail/20130521.r.44/photoshop/main/photoshop/xcode/../sources/UVMAccess.cpp : 783 : REQUIRE failed
2013:10:02 23:56:24 : /Volumes/workarea/PS_13.1_Mac_Daily_Retail/20130521.r.44/photoshop/main/photoshop/xcode/../sources/UVMAccess.cpp : 783 : REQUIRE failed

Is there a plugin that works like the scripting one that will force PS to dump log information that is readable by humans?
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 764 Reply Likes
No, there is nothing else for more logging. That log is meant for developers to read, not end users.

The error indicates that something in the document is in a corrupt state.

Were these files created in Photoshop CS 6, or a previous version?
Photo of Lisa Hainline

Lisa Hainline

  • 5 Posts
  • 0 Reply Likes
can't be layers or much when i can't even take a black and white jpeg and save it as a pdf.
Photo of Leigh-Anne Tompkins

Leigh-Anne Tompkins

  • 14 Posts
  • 2 Reply Likes
Try saving it in one of your external drives and then drag that file to your internal... then reboot your computer... Before launching on PS, do the repair permission first.

Leigh-Anne
Photo of Lisa Hainline

Lisa Hainline

  • 5 Posts
  • 0 Reply Likes
what do you mean by "repari permission" first? you mean insert disc and repair?
Photo of Leigh-Anne Tompkins

Leigh-Anne Tompkins

  • 14 Posts
  • 2 Reply Likes
I don't know about Windows maintenance, but on a Mac, we must do Repair Permission if something is not acting right. See the info re: Repair Permission on Apple computers... http://support.apple.com/kb/HT1452
Photo of NTruso .

NTruso .

  • 1 Post
  • 0 Reply Likes
It happens to me with some Mask Layers, i found that changing the Feather value sorts the problem out.
Photo of Martin Ciboch

Martin Ciboch

  • 1 Post
  • 0 Reply Likes
I change the Feather mask value and than the problem out.

Thank you!!!
Photo of Leigh-Anne Tompkins

Leigh-Anne Tompkins

  • 14 Posts
  • 2 Reply Likes
Try again when the OS extensions are tuned off. If it works, then one of the third parties is the culprit.
(Edited)