Lightroom: Can't import directly from camera with 5d Mark III & Lightroom 4.1

  • 5
  • Problem
  • Updated 2 years ago
  • Solved
  • (Edited)
I have installed the new Lightroom 4 to import my RAW files from the canon 5d mark iii. I have also installed the Adobe Labs 4.1 release to help fix the bugs. I still cannot get the images to import. It automatically says "No photos or video found to import" and nothing happens.

Is there something that I'm missing or are the mark iii raw files still not yet supported by lightroom 4?
Photo of arielle roszkowski

arielle roszkowski

  • 4 Posts
  • 0 Reply Likes

Posted 7 years ago

  • 5
Photo of Lee Jay

Lee Jay

  • 990 Posts
  • 136 Reply Likes
4.1RC does support the 5DIII raw files.
Photo of arielle roszkowski

arielle roszkowski

  • 4 Posts
  • 0 Reply Likes
Yes, I know it will support the 5dIII raw files. However, it will only import them sometimes. I have to restart Lightroom again and agin and try to import multiple times before it will actually import the files. Half the time when I press import a message pops up that says "No photos or video to import" and then it freezes and I have to force quit Lightroom. This happens over and over and out of hundreds of pictures I have been able to import maybe 20. Something isn't right...
Photo of arielle roszkowski

arielle roszkowski

  • 4 Posts
  • 0 Reply Likes
It's a hit or miss. I restart Lightroom and it will upload the raw files and other times it doesn't and completely freezes.
Photo of Eric Richards

Eric Richards

  • 2 Posts
  • 0 Reply Likes
me too. Doesn't make any sense. Moody??
Photo of Richard Gauthier

Richard Gauthier

  • 2 Posts
  • 0 Reply Likes
I have the same problem with both lightroom 4.1 and image capture. if I put the card in a reader it's fine, but not directly from the camera
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15232 Posts
  • 2192 Reply Likes
Arielle, are you also importing directly from the camera? What platform/OS are you guys on?
Photo of arielle roszkowski

arielle roszkowski

  • 4 Posts
  • 0 Reply Likes
Yes I am importing directly from the camera. I'm using OS 10.7.2
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15232 Posts
  • 2192 Reply Likes
Official Response
http://forums.adobe.com/message/43165...

You cannot import directly from a connected Canon 5D (Mark I) when the camera is set to "PC Connect". (Importing from a connected 5D does work when the camera is set to "Print/PTP".)

We're looking into the issue.
Photo of Eric Richards

Eric Richards

  • 2 Posts
  • 0 Reply Likes
Not True. I have always downloaded from the Mark III on my iMac without any problems (IOS Lion or Mountain Lion). It's my MacBoook Pro that poses problems
Photo of Richard Gauthier

Richard Gauthier

  • 2 Posts
  • 0 Reply Likes
Hi Jeffrey,
I am using Mac OS 10.7.3. In my case, I can upload maybe 2 or 3 RAW files from either the CF or the SDHC (sandisk) but not the rest on any card. Again this issue also replicate with the Image Capture software of the Mac OS. There is no issue using the Canon EOS utility.
Photo of Harvey Sapir

Harvey Sapir

  • 17 Posts
  • 1 Reply Like
Having same intermittent download problems.
Computer - IMAC, latest MAC OS release
Camera _ EOS 7D, RAW files, Sandisk CF cards, downloading from Sandisk card reader.
LR4.1, using Copy and Convert to DNG.
Sometimes download / convert works fine, 10 mins later, some of the files are not downloaded at all, some of them are.
Haven't carried out any extensive testing, but problem could be with DNG convert, not download.
Had a card with 7 images on it,only the 7th image downloaded / converted , all others rejected in LR.
Took the same card through Canon download utility, downloaded all 7 as RAW files, no problems.
Then in LR, tried to copy / convert the downloaded RAW images to DNG. LR succeeded with all images, EXCEPT the 7th image that previously worked.
This is :frightening", more than the response issues.
Never know now if I can even get all my images onto the computer and into LR.
Photo of Kelly Jones

Kelly Jones

  • 10 Posts
  • 0 Reply Likes
Same issue here. The first time I reinstalled the release candidate it worked for me, this last time after half my raw files downloaded the rest were unable to import even after reinstalling (for a 3rd time). I now have half a client session imported and the other half in limbo. This with a 5DM3.
Photo of Orjan Ellingvag

Orjan Ellingvag

  • 7 Posts
  • 2 Reply Likes
Seems to be an issue with the "Don't import suspected duplicates" option in my version (LR 4.1 rc). When checked, LR will not import (add) nor syncronize correctly. Turned the duplicate filter off, and all new images were finally imported.
Photo of Warren Lee

Warren Lee

  • 1 Post
  • 0 Reply Likes
Just a comment from a very frustrated customer. I was in heaven when I was using 5D Mark II with Lightroom 3. Now I have 5D Mark III within Lightroom 4 (Mac OS 10.6.8). I am extremely frustrated because when I called Adobe to confirm the RAW support for 5D Mark III, the sale person told me it does support although the online info does not mention the new camera raw support. The sale person insists that it will support thus I purchased the software.

After upgrading my Mac OS to 10.6.8 requirement and installation of Lightroom 4 and I just found out that it will not recognize the new RAW format.

Here is my Order #0118975002, please educate your own sales team to learn about their products first before saying things that do not exist.

Any update when new RAW format will be supported correctly?
Photo of Scott Penner

Scott Penner

  • 1 Post
  • 0 Reply Likes
Lightroom version: 4.1 [829322]
Version: 10.7 [4]
Application architecture: x64
Physical processor count: 4
Processor speed: 2.6 GHz
Built-in memory: 8192.0 MB

Canon 5d mk iii v1.1.3

Same problem
Photo of Karla Lock

Karla Lock

  • 1 Post
  • 0 Reply Likes
Lightroom: 4.1
Version: 10.8.1

5D MK III / firmware 1.1.3

Also have the same problem.

Have tried everything but it only works every now and then.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15232 Posts
  • 2192 Reply Likes
Official Response
This issue was fixed in Lightroom 4.2 and later.
Photo of P Gribben

P Gribben

  • 1 Post
  • 0 Reply Likes
`I am still having the same trouble with Lightroom 6 and my Canon 5D....
Photo of Geneva Nelson

Geneva Nelson

  • 1 Post
  • 0 Reply Likes
Has there been any resolution? I just purchased a Canon 5D Mark III and can't upload to Lightroom 4.4. Either directly from the camera or a card reader. Getting panicked!