Lightroom: 5.2 Update Adds Bug to exiting Full Screen Preview Mode

  • 9
  • Problem
  • Updated 4 years ago
  • Solved
  • (Edited)
The Lightroom 5.2 update added a bug to the Full Screen Preview mode.

Previously, when in Full Screen Preview mode and you hit a quick key to enter a module (rather than exiting by hitting "F") it would simply exit the Full Screen Preview mode and enter said module without changing your screen mode, but now...

Now when I exit with "F" everything is fine, but if I exit with "Esc", "D", "G", or "E" then it takes me OUT of Full Screen and into Normal.

This is incredibly frustrating.
Photo of Michael Rork

Michael Rork

  • 10 Posts
  • 0 Reply Likes
  • frustrated

Posted 5 years ago

  • 9
Photo of Erik Underbjerg

Erik Underbjerg

  • 1 Post
  • 0 Reply Likes
I have exactly the same problem with Lightroom 5.2 on Mac OSX 10.8.5. I always work in full screen screen mode, and often toggle full screen preview mode with the F key (great feature). This worked perfectly in 5.0, but on 5.2, Lightroom frequently kicks me out of full screen mode, when exiting full screen preview mode.

I can confirm the behaviour Michael explains, with one addition: If I am in Full Screen mode, enters Full Screen Preview (by pressing F), and then rapidly presses the F key two times in a row, Lightroom also revert to "Normal" screen mode.

It's very fustrating.
Photo of luc Renambot

luc Renambot

  • 5 Posts
  • 1 Reply Like
same here, yes, very annoying, please fix.
Photo of Jeff Charles

Jeff Charles

  • 2 Posts
  • 0 Reply Likes
Full Screen Preview was a nice new features in 5. This 5.2 bug has made it annoying and less useful.
Photo of Jeff Charles

Jeff Charles

  • 2 Posts
  • 0 Reply Likes
Not fixed in 5.3 RC. This is a defect.
Photo of LondonYank

LondonYank

  • 3 Posts
  • 0 Reply Likes
Yes, this is driving me mad as well.

My workflow has me switching very frequently between Grid and Fullscreen or Develop and Fullscreen and when I am in mid-workflow, I want Lightroom to remain in "full screen" window mode if that's what I specified when I return to Grid or Develop.
Photo of Erik Underbjerg

Erik Underbjerg

  • 2 Posts
  • 0 Reply Likes
This is still not fixed in 5.3 which I just installed.
Photo of Michael Rork

Michael Rork

  • 10 Posts
  • 0 Reply Likes
I confirm it's still not fixed with 5.3. Hey Adobe! This is a huge oversight! At least acknowledge us!
Photo of Der Dembo

Der Dembo

  • 5 Posts
  • 0 Reply Likes
Same for me - Lightroom 5.3 on MacBook Pro Retina (2013) running OS X 10.9.1
Photo of Michael Rork

Michael Rork

  • 10 Posts
  • 0 Reply Likes
I'm still REALLY frustrated this hasn't been fixed. Using Full Screen Preview is an essential part of my workflow and going back and forth between it and gallery mode quickly without having to remember to hit "f" first is tiresome. PLEASE fix this soon! It's been 5 months since I reported the problem and I'm SURE someone at Adobe is annoyed by it as well! Julieanne Kost, doesn't this bug you?
Photo of Michael Rork

Michael Rork

  • 10 Posts
  • 0 Reply Likes
I'm going to start commenting here and posting to the Facebook page every time I use Lightroom and the problem hasn't been updated to "working on".
Photo of Michael Rork

Michael Rork

  • 10 Posts
  • 0 Reply Likes
Official Response
FIXED! This has been fixed with 5.4! WOOOOT!
Photo of Michael Rork

Michael Rork

  • 10 Posts
  • 0 Reply Likes
I can't figure out how to mark this as solved.
Photo of John Thomas

John Thomas

  • 5 Posts
  • 0 Reply Likes
Lightroom doesn't allow me to exit Full Screen Mode to go to another view. After I initially press the F key to get to full screen mode it won't allow me to get back to other modes. I have to restart LR to get to another view and use LR again. Wish someone would come up with a fix. I am running 5.4
Photo of John Thomas

John Thomas

  • 5 Posts
  • 0 Reply Likes
I see that this is marked as solved when it isn't.
Photo of Erik Underbjerg

Erik Underbjerg

  • 2 Posts
  • 0 Reply Likes
John, it sounds like you are having a slightly different issue than the issue this report was originally about.

The issue Michael Rork described was fixed for some of us in 5.4, albeit after a rather long wait.

I would suggest you open a separate issue for what you're experiencing.
Photo of John Thomas

John Thomas

  • 5 Posts
  • 0 Reply Likes
Thanks, I just took your advise.