Photoshop CC: 3D Not Working, can't move, pan etc in the 3D workspace.

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
Hi

I'm able to import an OBJ file and view it in a document, but can't move it at all using the 3D tools.

No 3D axis controls appears in the screen, and the 'forbidden' icon (black circle with diagonal line through it) appears if I try to move, pan etc in the 3D workspace.

Im using a Mac running El Captan 10.11.1 Photoshop CC 2015 with 32Gb of memory and this graphics card (NVIDIA GeForce GTX 680MX 2048 MB).

I can run other 3D applications like MODO on the Mac with no issues at all.

PLEASE HELP!
Thanks
Photo of Pali Rao

Pali Rao

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 1
Photo of Daniel Presedo

Daniel Presedo, Employee

  • 46 Posts
  • 15 Reply Likes
Maybe a screen shot would help of the 3d file on canvas with the Layers panel.

When you import the 3D file > does it have the 3D cube icon on that Layer? Just want to make sure it did not gat Placed a smart object or get rasterized.

What kind of Mac machine is this?

We may need more information and I would start with this thread if this an older Mac Pro > https://discussions.apple.com/thread/...

This might help narrow it down, if it is indeed a driver issue and not something else.
Photo of Pali Rao

Pali Rao

  • 2 Posts
  • 0 Reply Likes
Hi Daniel

Many thanks for relying so quickly.

When I import the item, I can see the geometry on the screen, and turn on/off layers, but no 3D cube icon appears.

It's a iMac (not a PC Mac) - please find details attached. 3D used to work ok (but I've not tried for a long time).

I've been using MODO which seems to be coping just fine with much more complex geometry and rendering on the same machine. I've even imported the same OBJ file into MODO and rendered images.

Any advice appreciated!

Thanks
Photo of David Dobish

David Dobish, Senior QE Photoshop

  • 197 Posts
  • 50 Reply Likes
Also you could try to just reset the prefs.  Perhaps something got messed up.  I would immediately after you double click to launch app, hold down the cmmd+alt+shift keys and then click OK to reset preferences.  This may help too.
(Edited)