Photoshop: 2nd Save For Web export from script never works

  • 1
  • Problem
  • Updated 7 years ago
  • (Edited)
Hi Photoshop,

I noticed a bug concerning the scripts.
Whenever I make a script including an export for web + closing the file without saving, the 2nd export never works. I have to re-open the 2nd file and apply the script again everytime. I tried on different computers and different versions of Photoshop and this problem is recurring.

Thanks

Olivier
Photo of Olivier Massain

Olivier Massain

  • 1 Post
  • 0 Reply Likes

Posted 7 years ago

  • 1
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1224 Posts
  • 172 Reply Likes
Unless you provide your Script that seems hard to verify.
How do you trigger the Script anyway and does it have file- or folder-selection?
Or are you actually talking about an Action?
Photo of PECourtejoie

PECourtejoie, Champion

  • 792 Posts
  • 285 Reply Likes
Christoph, that's quite possible, because unfortunately, Actions are called Scripts in the French translation. I hope this gets resolved in the future.

Olivier, do you absolutely need save for web? did you try the image processor in File>Scripts ? it might fit the bill. (and there is a counterpart in Bridge, letting you select images and run a batch on them...)
Photo of christoph pfaffenbichler

christoph pfaffenbichler, Champion

  • 1224 Posts
  • 172 Reply Likes
Well, that’s certainly an invitation to confusion.
Photo of PECourtejoie

PECourtejoie, Champion

  • 792 Posts
  • 285 Reply Likes
I already let the localization folks know about it.
Photo of Paul Riggott

Paul Riggott

  • 359 Posts
  • 143 Reply Likes
Image Processor does not support Save For Web
Picture Processor does though...
http://www.scriptsrus.talktalk.net/PP...