2015 undo command behavior changed (Now acts like step backward)

  • 2
  • Problem
  • Updated 3 years ago
Why has the undo feature changed? I know it seems like a small shift but it has completely messed up the way I have worked in Photoshop for years. It now just alternates step backward/forward when it used to undo a chain of commands. If I'm not making sense, here's a case study.

2014:
Create a shape. Nudge it right 50px by using shift+right arrow. Cmd+z (undo) takes it back left 50px. If I wanted to go back nudge by nudge 10px at a time, I would use cmd+opt+z (step backwards).

2015:
Create a shape. Nudge it right 50px by using shift+right arrow. Cmd+z (undo) takes it back left one nudge (10px). cmd+z again moves it right one nudge. Continued undo just moves it back and forth.

For those of us who use a keyboard workflow for UI design to make sure we are always correct to the pixel on placement, grids, padding, etc., this is a huge interruption that slows us way down and I can't find any preferences to go back to the old behavior. Now if I'm nudging and make a mistake, I have to figure out where I started all over or step backwards a number of times and hope I don't accidentally press a couple too many and not notice undoing some other change.
Photo of Vincent Le Pés III

Vincent Le Pés III

  • 15 Posts
  • 2 Reply Likes
  • frustrated

Posted 3 years ago

  • 2
Photo of Kevin Gent

Kevin Gent

  • 2 Posts
  • 0 Reply Likes
Completely agree. I've been using Photoshop for years and this change is very annoying. Please just make a toggle in the preferences menu allowing us to choose which way we like our undo to work.
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 823 Reply Likes
The behavior of undo and step backward haven't changed at all in Photoshop CC 2015.
Photo of Vincent Le Pés III

Vincent Le Pés III

  • 15 Posts
  • 2 Reply Likes
Something is amiss. I worked for a few days with it having changed, still not quite used to it, and then one day it started working again the way it used to. I think there's a bug behind this. I'll report back if it starts doing it again, but apparently I'm not the only one who experienced it.
Photo of Kevin Gent

Kevin Gent

  • 2 Posts
  • 0 Reply Likes
It must be a bug.

I've checked for updates and tried the usual restarting my computer / Photoshop and its still around.

Let me know if anyone finds a fix for this.
Photo of Vincent Le Pés III

Vincent Le Pés III

  • 15 Posts
  • 2 Reply Likes
Wait and hope? Haha, I know that's no kind of answer. Unfortunately I have no idea what triggered it to start working correctly, it just did one day. I hadn't even run an update.
Photo of Vincent Le Pés III

Vincent Le Pés III

  • 15 Posts
  • 2 Reply Likes
I still think it's an issue worth looking into on Adobe's side. It was seriously messing with my productivity the first few days.