Photoshop CC 2015.5: Generator can't export nested groups. Inconsistent export of groups or grouped layers with "zeroBoundsError"

  • 6
  • Problem
  • Updated 3 years ago
  • Solved
  • (Edited)
Fist off, I'm glad to hear that there were improvements made to the built in Generator. I'm sure they are wonderful. Unfortunately, I do not get to benefit from them because the majority of the layers I have named with the Asset Generator syntax now refuse to export.

I have a photoshop file with several artboards. They are the same size and represent different screens in a user flow. I did this so we can leverage the device preview and artboards-to-pdf features.

Each artboard is named with generator syntax to produce a "screen preview". Each artboard also contains layer groups named with generator syntax. Some of these groups are nested within other groups in a heirarchy because the screens can get pretty complex.

In this screenshot, only previews/Preview_Transition01.png is exported. Transition_Curtain_Logo.png and others fail...


These all exported nicely in CC 2015.1. After the update to 2015.5, only the artboard previews and an occasional top level group are being exported. Any child groups/layers fail or are frustratingly inconsistent.

The generator logs indicate that the layers start to render, but then get an error and fail:

[info:generator-assets 10:48:17.039 C:\Program Files\Adobe\Adobe Photoshop CC 2015.5\Required\Plug-Ins\Generator\assets.generate\lib\rendermanager.js:157:30] RenderManager active
[info:generator-assets 10:48:17.060 C:\Program Files\Adobe\Adobe Photoshop CC 2015.5\Required\Plug-Ins\Generator\assets.generate\lib\rendermanager.js:178:26] Rendering: Transition_01_Bubble_Art_01.png (7;1)
[error:generator-assets 10:48:17.313 C:\Program Files\Adobe\Adobe Photoshop CC 2015.5\Required\Plug-Ins\Generator\assets.generate\lib\assetmanager.js:449:34] Render failed: Transition_01_Bubble_Art_01.png { [Error: Refusing to render pixmap with zero bounds.] zeroBoundsError: true }

If I look at the JSON extracted from a call to the generator API to get the document and layer information, I can see that all failing layers return with valid bounds:
//...
{
"id": 680,
"index": 676,
"type": "layerSection",
"name": "50% ThemeStore_Art-04.png",
"bounds": {
"top": 0,
"left": -2048,
"bottom": 6048,
"right": 9174
},
"visible": true,
"clipped": false,
"blendOptions": {
"mode": "passThrough"
},
"generatorSettings": false,
//...

A bit of experimentation reveals that:
- Most of the problems are resolved by removing *all* artboards and having all contents in a single traditional canvas.
- If I move the named layer groups outside of the artboard, they will export correctly... sometimes.
- If I add layer masks on *every* layer and group in the tree path I want to export, it seems to work sometimes.
- If I keep the export layers/groups nested only one folder deep, it seems to work sometimes.
Photo of Max Johnson

Max Johnson, Champion

  • 603 Posts
  • 318 Reply Likes
  • frustrated

Posted 3 years ago

  • 6
Photo of Max Johnson

Max Johnson, Champion

  • 603 Posts
  • 318 Reply Likes
Further testing with a generator json config has revealed that the following settings have NO effect on the problem:

c:/users/USERNAME/.generator.json


{

"generator-assets": {

"include-ancestor-masks": true,

"clip-all-images-to-artboard-bounds": false,

"clip-all-images-to-document-bounds": false

}

}


Unless my syntax is off?
(Edited)
Photo of Chad Rolfs

Chad Rolfs, Employee

  • 103 Posts
  • 52 Reply Likes
We are aware of this and have a fix ready.  Unfortunately PS just shipped with this bug.  :(
https://helpx.adobe.com/photoshop/kb/generate-and-export-as-failure.html
Photo of Max Johnson

Max Johnson, Champion

  • 603 Posts
  • 318 Reply Likes
Thanks for the fast response! I am happy and sad now?
I guess I just have to wait on updating until the next incremental update?
Photo of Chad Rolfs

Chad Rolfs, Employee

  • 103 Posts
  • 52 Reply Likes
We are too.  We are hoping to get it out VERY soon.
Photo of Max Johnson

Max Johnson, Champion

  • 603 Posts
  • 318 Reply Likes
I am very appreciative of your candor and time. Tell whomever it may concern that I have a virtual high-five waiting for them. :)
Photo of Silviu Bucsa

Silviu Bucsa

  • 1 Post
  • 0 Reply Likes
Any ETA on when this fix will be pushed?

Any other more technical way to fix Generator so we won't have to move back and forth between PS versions? 
Photo of Isa W

Isa W

  • 1 Post
  • 0 Reply Likes
Thanks for the link. Suggestion #2 worked for me (un-nesting folders named for generating). Still looking forward to the real fix though!
Photo of Chad Rolfs

Chad Rolfs, Employee

  • 103 Posts
  • 52 Reply Likes
Fix will be pushed very soon but I can't publicly disclose any dates.  Thank you for your patience.
Photo of Max Johnson

Max Johnson, Champion

  • 603 Posts
  • 318 Reply Likes
So generate! Very Fix! Much excite!
Photo of Dave Mozdzanowski

Dave Mozdzanowski

  • 24 Posts
  • 1 Reply Like
Just to add a bit more info to this post, though I know Adobe is aware and working on a fix, more info can't hurt, right?

I'm getting the following error when I right-click on a layer-group(that is not, in fact, empty as the error states) within an artboard and click "Export As..":



Hope that helps! Looking forward to a fix!
Photo of Chad Rolfs

Chad Rolfs, Employee

  • 103 Posts
  • 52 Reply Likes
Yep, same root cause.  We have a fix ready to go.  Thanks!
Photo of Dave Mozdzanowski

Dave Mozdzanowski

  • 24 Posts
  • 1 Reply Like
Great, thanks for the quick reply!
Photo of David Howe

David Howe

  • 4 Posts
  • 1 Reply Like
This reply was created from a merged topic originally titled Photoshop: Generate group won't save if it's nested.

I use Generate a lot, and have always had the odd issue, but nothing a good old close and reopen wouldn't fix. However since updating to Photoshop 2015.5 if I try to use generate on a nested group, it won't save it out. It's fine if you're using generate on a single layer, that can be buried inside as many groups as you like. But if you are using generate on a group, and that group is inside another, then it won't save it out. Could this be looked into ASAP and fixed please, as it is really annoying having to make my files less organised in order for it to work.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 16159 Posts
  • 2555 Reply Likes
Official Response
Please install the CC 2015.5.1 update that was released tonight to correct this issue: http://blogs.adobe.com/crawlspace/2016/08/photoshop-cc-2015-5-1-update-now-available.html