Photoshop: "To use Creative Cloud Libraries please update the Creative Cloud Application"

  • 3
  • Problem
  • Updated 11 months ago
  • In Progress
  • (Edited)
Hello !
Today when I opened my PC I was notified that the Creative Cloud Desktop Application needs to be updated.
I clicked on update, waited for it to finish and sadly it ended up with an error and I had to use Creative Cloud Cleaner Tool to uninstall it. It has uninstalled successfully..
After reinstalling it, Photoshop no longer sees my libraries. I have tried all the help links from adobe help website to fix the sync, delete sync file, sign in, sign out.
Nothing works, I cannot see my libraries inside photoshop.
I get the message in the title: "To use Creative Cloud Libraries, please update the Creative Cloud Application.
Photo of CristianC25

CristianC25

  • 46 Posts
  • 22 Reply Likes

Posted 1 year ago

  • 3
Photo of CristianC25

CristianC25

  • 46 Posts
  • 22 Reply Likes
Hello Steve,

I've also performed the above change and moved the folder "CC_LIBRARIES_PANEL_EXTENSION_2_14_207" to my desktop.
My Photoshop libraries are also now back to normal and working.
I am sorry for replying so late, I have a different timezone as well. I'm from Romania.
Thank you very much for your help, I will keep eyes on this thread for further messages from you as you mentioned.

All the best,
Cristian.
Photo of CristianC25

CristianC25

  • 46 Posts
  • 22 Reply Likes
Hello!
I'm bringing bad news again.
Creative Cloud failed to update again today.
During update It was asking me to replace some folders. Clicking yes or no didn't do anything but to corrupt the update of the application.
Then I ended up with a GPUCache folder on my desktop and with Creative Cloud refusing to load. Same as before. I guess I have to uninstall it again, my God...this is such a pain.
(EDIT); I've used the cleaner tool again and reinstalled the latest version from the Adobe Creative Cloud website - download button. It reinstalled successfully and now the version number is 4.6.0.384
(EDIT2) I have removed "CC_LIBRARIES_PANEL_EXTENSION_2_14_207" again and this time no longer makes the Creative Cloud library work inside Photoshop. Gives same error as before.

An additional bug or problem. Starting Creative Cloud now creates a GPUCache on my desktop everytime.
Others have encountered this problem also and have posted here: https://forums.adobe.com/thread/2511010
(Edited)
Photo of CristianC25

CristianC25

  • 46 Posts
  • 22 Reply Likes
Is anyone still following this thread? The problem isn't fixed and there's a 2nd problem now with that GPUCache folder appearing on desktop when you start Creative Cloud App.
Photo of SG...

SG..., Employee

  • 144 Posts
  • 39 Reply Likes
Hi,

Yes, we are. I have replied in the U2U forum on the GPUCache issue (but don’t have an understanding of the root cause yet).

When you had/have the 2_14_207 extension in the installed location, did/do you see the same original error?

Can you go to C:\Program Files (x86)\Common Files\Adobe\Creative Cloud Libraries\CCLibrary.exe and tell me the version that’s reported either in the tool tip or under Properties | Details?

thx,
steve
Photo of CristianC25

CristianC25

  • 46 Posts
  • 22 Reply Likes
Hello,
Thank you for your patience and help.
I saw your reply in U2U forum, I didn't know it was you. I replied there about the GPUCache.

1) I have received pretty much the same error, yes. (EDIT) This time it says "To use Creative Cloud Libraries please install the Creative Cloud Application" instead of "Update" the Creative Cloud Application.
This time I receive the same error with the workaround in place. (2_14_207 folder moved to my desktop)
2) Yes, here is a screenshot with the Properties | Details of the app.
(Edited)
Photo of CristianC25

CristianC25

  • 46 Posts
  • 22 Reply Likes
These steps solved the appearance of the GPUCache on the desktop. https://forums.adobe.com/message/10492296#10492296

The first problem still persists.
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 725 Posts
  • 327 Reply Likes
Thanks for sharing those steps here Cris.
Photo of CristianC25

CristianC25

  • 46 Posts
  • 22 Reply Likes
No problem, my pleasure to help. I hope we finally fix the main problem with CC too.
Photo of OmiVT

OmiVT

  • 4 Posts
  • 6 Reply Likes
Hi Cristian, were you able to solve the library issue?
Photo of CristianC25

CristianC25

  • 46 Posts
  • 22 Reply Likes
No, I haven't. It was kinda of solved until latest Creative Cloud update. Right now libraries are again not working and are giving me the above message. I didn't post anything else because I was waiting for a reply if it ever comes.
(Edited)
Photo of CristianC25

CristianC25

  • 46 Posts
  • 22 Reply Likes
I'm pretty much upset on this issue. Reinstalling Photoshop doesn't fix it either. I cleaned everything. The CC and PS simply refuse to communicate.
Photo of OmiVT

OmiVT

  • 4 Posts
  • 6 Reply Likes
I've also tried updating my Photoshop but it didn't work. Hope they could fix this issue soon.
Photo of SG...

SG..., Employee

  • 144 Posts
  • 39 Reply Likes
Hi,

The workaround of moving the 2_14_2-7 extension to the desktop should not be needed at this point. There was a mandatory Creative Cloud desktop update ( 4.6.0.384) which contributed to the initial problem; if you are still having problems with that update we'll need to work through it.

The expected baseline for the Libraries to be working is the "CC_LIBRARIES_PANEL_EXTENSION_2_14_207" is present in the Common Files location. If it is can you check the version of the running background service?

1) right click on Taskbar and select 'Task Manager'

2) go to the 'Details' tab and scroll to CCLibrary.exe

3) right click on the process and select 'Properties'

4) in displayed dialog go to Details tab

What is the file version?

If you don't see that process, then you'll need to launch it.

C:\Program Files (x86)\Common Files\Adobe\Creative Cloud Libraries\CCLibrary.exe


regards,

steve
Photo of CristianC25

CristianC25

  • 46 Posts
  • 22 Reply Likes
Hello!
My CCLibrary.exe version is 2.14.9.3.
I've posted this a few days ago as a screenshot including the full details panel.
(Edited)
Photo of OmiVT

OmiVT

  • 4 Posts
  • 6 Reply Likes
Hi Steve,

I checked to see if the cclibrary.exe is running in the background, found out it wasn't so I launched it and it worked! My library is back to normal now. By the way, my CClibrary.exe version is also 2.14.9.3.

Thank you so much for the help!
Photo of OmiVT

OmiVT

  • 4 Posts
  • 6 Reply Likes
Hi, I'm having the same problem too. Moving "CC_LIBRARIES_PANEL_EXTENSION_2_14_207" worked for a while then "To use Creative Cloud Libraries please install the Creative Cloud Application" started appearing again. I've tried moving the 2_14_207 folder to my desktop again but it didn't work. I've also tried uninstalling and reinstalling my cc app and it still didn't work. I really don't know what to do :( 
Photo of Rosa

Rosa

  • 409 Posts
  • 222 Reply Likes
Hi OmiVT

I think the problem still exists. I have had succes with moving the folder to my desktop but as yet not had a permanent fix to the problem.

Cheers
Rosa
Photo of Thomas Chen

Thomas Chen

  • 2 Posts
  • 4 Reply Likes
Hi everyone!

After spending around two days on this issue, I finally managed to solve it! 
I feel like Creative Cloud is either not functioning properly in the newest version or there's a problem with the server.
I'll go over the steps that I took- Hope this helps!
Make sure all creative cloud apps are closed, including creative cloud.
1. Go into C:\Program Files (x86)\Adobe. Delete all "Adobe Creative Cloud" files.
2. Go to C:\Program Files (x86)\Common Files\Adobe. Delete Creative Cloud Libraries and Coresync.
3. Go to C:\Users\Username\AppData\Roaming\Adobe. Delete Creative Cloud Libraries and Coresync.
(If you cannot delete any of those folders, you haven't closed Creative Cloud properly! Open task manager, end Adobe CEF Helper, Update Service, CCLibraries, CCXProcess, Core Sync, Creative cloud)
4. Download Adobe Creative Cloud uninstaller. It should run very quickly and end successful.
5. Download Adobe Creative CloudYou must download it from this link! Do NOT download it directly from the website.
6. Choose Download using direct download links.
7. Download the zip file, extract to somewhere.
8. Run the exe file.
(Take note that this process should be relatively quick- shouldn't take more than 30 minutes. If an error comes up, such as server connection issues, etc, you probably did something wrong! You can retry, but the chances of you having problems is high.)
9. Creative cloud should open once it's done. 
10. Click on three dots>preferences.
11. Uncheck "Always keep...up to date."
12. Click Creative Cloud tab>Files> Check and uncheck file sync.
13. Go into C:\Program Files (x86)\Common Files\Adobe\CEP\extensions\ and delete CC_LIBRARIES_PANEL_EXTENSION_2_14_207 if it exists. (Thanks SG!)
14. Open a program. It should work now!
Do NOT update Creative Cloud! I tried doing this and it stopped working again. You should be set on version 4.5.0.331 and Sync 3.0.3.6.
I have tried restarting and everything still works after.
Make sure your hosts file isn't blocking anything with adobe in it.

Thanks to everyone who provided assistance! Hope everyone can get their libraries working again :)
Photo of CristianC25

CristianC25

  • 46 Posts
  • 22 Reply Likes
This is a fix for the older version, already did most of these steps days ago when SG first replied with the metod of removing that folder. What you are saying is that we should stick to an older version because it works. I guess I'll have to do that if the newer version isn't working properly.
(Edited)
Photo of CristianC25

CristianC25

  • 46 Posts
  • 22 Reply Likes
@SG...
Double clicking CCLibrary.exe from its destination folder after launching Creative Cloud App, makes the libraries work. The process doesn't want to start automatically when launching Creative Cloud. Manually starting CCLibrary.exe has started the libraries in Photoshop. (same method as OmiVT said above)
(Edited)
Photo of Thomas Chen

Thomas Chen

  • 2 Posts
  • 4 Reply Likes
Although I know that Creative Cloud isn't working right, I did my best to fix the issue.
Sadly, if you don't update, you temporarily lose access to the creative cloud program, which is undesired.
However, none of you want to constantly re-open CCLibraries everytime your computer opens.

I went and made a task scheduler that opens CCLibrary whenever the computer logs on. As long as you don't quit the program, you should be able to use it fine without any issues. I could design it to open whenever Creative Cloud is opened, but that's much more complicated and requires other programs.

This "fixes" the newest version for now. It can be deleted when the problem is fixed.
You can download it at this Dropbox link. It's just an xml file, so don't worry about downloading anything extra. It's pretty simple to add as well.

1. Open the run prompt (windows key+r)
2. Type in taskschd.msc and press OK.
3. Click on the Task Scheduler Library.
4. Look on the toolbar on the right. There should be something that says "Actions" in bold.
5. Open the Task scheduler library if it isn't already.
6. Click "Import Task"
7. Find wherever you downloaded the xml file. Import it in and press OK.
8. You may now delete the file from wherever you downloaded it.
9. Click on the CCLibrary task, and click Run (under the Actions, Selected Item).

This will, for now, stop you from needing to open CCLibrary every time you need to use your Library.
Hope this helps!
This is working and tested for the latest version of Creative Cloud. If the issue is later fixed, you actually don't need to delete the task- it won't affect anything program side but might make computer startup slightly longer. 

Good luck!
Photo of CristianC25

CristianC25

  • 46 Posts
  • 22 Reply Likes
Hello! Today I received another update for Creative Cloud and now the libraries are working. Problem is fixed for now. Thank you for your help and work for fixing this.
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 725 Posts
  • 327 Reply Likes
Glad to hear it Christian. We really appreciate the follow up! :) 

Hannah