[Technical] How do I manually disable GPU in Lightroom 6? (OS X )

  • 1
  • Problem
  • Updated 2 years ago
Every time I open Lightroom and Photoshop my computer freezes.

That's because there's a hardware fault with my Macbook Pro 2013 10.11.5 - due to water damage and the GPU circuit has been affected.

I was OK with things until Lightroom updated to 6.6 from 6.5 because somehow it's managed to re-enable GPU performance.

I've read this article but the manual fix is only really for Windows. I did even look for the key (useAutoBahn) in the Lightroom 6 plist file but to no avail. Tried adding it too but the issue keeps happening.

Then I came across this article about disabling graphic switching in OSX but again that's made no change - not even sure it would really work.

Ideally if I can get the right key/value for Lightroom 6.6 (and Photoshop) then I should be OK.

Please help!
Photo of CCV

CCV

  • 4 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1490 Posts
  • 471 Reply Likes
https://helpx.adobe.com/lightroom/kb/lightroom-gpu-faq.html Turn off the GPU Acceleration from the Lightroom user preference dialog. No need to edit the user pref files manually.
(Edited)
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1490 Posts
  • 471 Reply Likes
There is a similar preference setting for Photoshop and the camera raw settings.
Photo of CCV

CCV

  • 4 Posts
  • 0 Reply Likes
Sadly I can't get that far into Lightroom or Photoshop to switch it off as they both freeze as the splash screen comes  up :( I have no choice but to force shutdown.
(Edited)
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1490 Posts
  • 471 Reply Likes
If you cannot even launch Lightroom because of this, then the instruction to manually disable the graphics processor in this article will work for Windows. For Mac, the instruction is similar. However, the user preference file is located at "/Users/your login account/Library/Preferences/com.adobe.Lightroom6.plist". You probably need a special .plist editor for this. Search for the same "useAutoBahn" key and change it from YES to NO.
Photo of CCV

CCV

  • 4 Posts
  • 0 Reply Likes
I've already done that Simon - there is no setting called that. I've even added it but no change.

The setting has to be saved somewhere.

Possible second option: As a different way to fix this.. Could someone very very nice upload their plist (with GPU performance disabled that is). It could let me open up Lightroom again (albeit with the other persons preferences).
Photo of CCV

CCV

  • 4 Posts
  • 0 Reply Likes
Managed to fix it!. Copied the plist from a friends macbook air and now back in to Lightroom. Working on Photoshop!