Photoshop: ‘Stroke path with mixer brush’ problems when applied as part of an action to video layer

  • 1
  • Problem
  • Updated 10 months ago
  • (Edited)
Part of my process involves (or at least would involve) stroking a work path with the mixer brush tool as part of a custom action.The mixer brush tool will simply stroke a white line (or other foreground colour) when applied as part of an action to a video layer. The bug seems to involve not utilising the ‘sample all layers’ option which is selected. Other mixer brush settings seem to be ignored too (such as ‘clean brush after each stroke). If these minor bugs could be resolved my work would be infinitely easier and it would greatly speed up my workflow. Any help or ideas would be greatly appreciated. I am running a current and updated version of Photoshop CC.The problem does not apply when using layers rather than a video layer (such as applying the action to a frame animation).The problem does not apply when double clicking the ‘stroke path’ part of the action, it only seems to apply when played as part of a sequence of actions, and only when using video layers.
Photo of d S

d S

  • 7 Posts
  • 1 Reply Like

Posted 10 months ago

  • 1
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15633 Posts
  • 2369 Reply Likes
Hi d S, do you know off-hand if this has always been a problem or something new in CC 2019? I suspect the former as video layers use a virtual layer/frame for non-destructive changes. Let me check with our video engineer and see if there's anything we can do to try and improve this.
Photo of d S

d S

  • 7 Posts
  • 1 Reply Like
Hi Jeffrey, thanks for your reply.
I have been able to test the issue on CS6 and CC2018 with the same results, so yes I think this has always been an issue.
Thanks again,
Daniel