Lightroom CC: "Some Photos Invalid" bug when editing while syncing to cloud

  • 1
  • Problem
  • Updated 1 year ago
  • (Edited)
In short: on Windows 10, after import and during cloud sync of smaller amount (90) RAW images Lightroom CC started showing a red exclamation mark reading "Some Photos Invalid".

Looked up the forums, found an official hint that in this case those photos marked corrupt (?) need to be imported again. 

Which in some case indeed is a solution, but the source of the issue isn't any corruption in the files or during import, but is rather a bug in Lightroom CC itself.

So the "issue" was that during the upload process I already started flagging some of the photos as picked, also edited some (BTW, why wouldn't I? upload of RAW's take long and since I'm already able to browse my imported photos, I'd like to start editing right away).
It seems that this makes Lightroom's sync failing, and after a point all photos which are still in the upload queue would start to fail to upload and being marked incorrectly as corrupt - even if those aren't marked/edited yet.

I could've reproduce this several times until I found out that I need to wait patiently until all photos are uploaded in the cloud and start marking and editing only afterwards.

This whole issue is a serious flaw in syncing photos and should be fixed.
Photo of abrax

abrax

  • 15 Posts
  • 1 Reply Like

Posted 1 year ago

  • 1
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7541 Posts
  • 1728 Reply Likes
abrax,

Can you go to Help>System Info... and get us the installed Lightroom version number?
Photo of abrax

abrax

  • 15 Posts
  • 1 Reply Like
Hi Rikk,

It's 2.2, 20190204-1600-e7ae100 Build, running on Windows 10 Pro.

Should be the most recent one, I always keep the Adobe Creative Cloud updated.
(Edited)
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7541 Posts
  • 1728 Reply Likes
Thanks for the update.  If this is reproducible and not a one-time occurrence we would like to get more information from you. 
  1. A copy of the invalid file. 
  2. The Import source (card reader, port, etc)
  3. A Full Report (Preferences>Account and hold down [Alt/Opt] and click Full Report button that appears.
Send all to me at