"Put new Person Keywords Inside this Keyword" doesn't work with the People function

  • 1
  • Problem
  • Updated 9 months ago
  • Not a Problem
I created a top-level keyword "People" and checked "Put new Person Keywords Inside this Keyword" in the context menu. Unfortunately names that I type when I use the People function to sort through a bunch of detected faces are still put on the top level.

Same happens when I drag and drop photos from the section "Unnamed People" onto one stack in "Named People". Even when a keyword belonging to a hierarchy is already assigned to the target stack, the photos added get new keywords on top level. So I have to alter them to "Name < People" every time.
Apparently the functions around face detection are mostly ignoring keyword hierarchy. This renders "Put new Person Keywords Inside this Keyword" useless and makes using hierarchies for people-keywords pretty much a no-go as well.
Photo of Henrik Zawischa

Henrik Zawischa

  • 88 Posts
  • 7 Reply Likes

Posted 9 months ago

  • 1
Photo of John R. Ellis

John R. Ellis, Champion

  • 3737 Posts
  • 978 Reply Likes
"I created a top-level keyword "People" and checked "Put new Person Keywords Inside this Keyword" in the context menu. Unfortunately names that I type when I use the People function to sort through a bunch of detected faces are still put on the top level. ... Apparently the functions around face detection are mostly ignoring keyword hierarchy."

I'm not able to reproduce this.   When I enter a new person tag above a person's face, it goes where I've indicated in the hierarchy. And if I type a name that exists in multiple places in the hierarchy, auto-completion shows me the matching heirarchical keywords and let's me choose.

1. Can you please do Help > System Info and report the exact version of LR and Mac / Windows?

2.  A screen recording of the behavior would be most helpful, but short of that, a very precise step-by-step recipe would help clarify what's going on.
(Edited)
Photo of Henrik Zawischa

Henrik Zawischa

  • 88 Posts
  • 7 Reply Likes
Hi John,
I was compiling the requested information when I noticed it works now. My original posting seems ridiculous, I can only assure you that it didn't work properly yesterday. What happened between yesterday and today? A restart of course. Not very plausible.
I wished I could show you yesterdays behaviour so that you don't think I am a complete idiot. But today I cannot reproduce it.
New person-keywords are created under People, keywords are no longer duplicated, neither by clicking the check-mark, nor by dragging the poto onto existing images under Named People. All is fine. But for the question which step required the restart.  But that is minor.
Sorry for this. And thanks for your help.
Henrik
Photo of John R. Ellis

John R. Ellis, Champion

  • 3737 Posts
  • 978 Reply Likes
Unfortunately, it's not uncommon for such problems to go away when you restart your computer or LR.  So no worries about posting.  If it comes back, be sure to post again.