Photoshop: "Ghost" files when saving

  • 2
  • Problem
  • Updated 1 month ago
  • (Edited)
When I save or export photos in LR or PS, they save but do not show up when I attempt to locate them in Finder.  They do show up ONLY via "File" > "Open" in PS.  

I did find a temporary workaround - when I go to File > Open in PS, I can drag/drop the folder into "My Documents" and then back onto "Desktop" and they show up in the regular finder.

Hard to explain, so I made a youtube video below:
https://www.youtube.com/watch?v=W4owx1NUqLA
Photo of Veronica Dziura

Veronica Dziura

  • 3 Posts
  • 1 Reply Like

Posted 2 months ago

  • 2
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15232 Posts
  • 2192 Reply Likes
That's very strange. Sounds like the desktop just isn't updating. Have you simply tried restarting your iMac?
Photo of Veronica Dziura

Veronica Dziura

  • 3 Posts
  • 1 Reply Like
Hi! Thanks for the response. I've restarted my mac and reset my preferences in PS. I've been having this issue since I got the iMac in early December! I spoke on the phone with an Apple agent and she says it's a compatibility issue and that she's never seen it before.  I don't have issues saving any other type of file - only Adobe.
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 15232 Posts
  • 2192 Reply Likes
Ugh. OK. Two other things I'd try:

1. Start in safe mode and see if you can reproduce the problem. This eliminates any driver or extension problems.
2. Troubleshoot user permissions by creating a new Admin User account and running Photoshop under the new account to see if the problem persists. 
Photo of Hannah Nicollet

Hannah Nicollet, Quality Engineer

  • 720 Posts
  • 315 Reply Likes
#2 resolved the issue for her
Photo of Veronica Dziura

Veronica Dziura

  • 3 Posts
  • 1 Reply Like
Jeff, thanks so much for taking the time to help with this - I made a new admin user account and I haven't had a single issue.  SUCH a relief, thank you again!!!
(Edited)