Lightroom Classic 9: "Dock Folder" not sticking in new import sessions

  • 3
  • Problem
  • Updated 4 weeks ago
  • Acknowledged
  • (Edited)
Lightroom Classic 9.1 seems to forget if a folder has been selected to be docked in the folder tree on the left panel when importing. When starting a new import session, the checkmark is gone and the selection has to be done all over again. This is unfortunate if the folder to be docked is deep within a folder structure.

It seems to be a bug. Can Adobe please fix this in one of the next releases?
Thank you!
Photo of Johannes Kälber

Johannes Kälber

  • 5 Posts
  • 1 Reply Like

Posted 6 months ago

  • 3
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7641 Posts
  • 1741 Reply Likes
Can you provide a screenshot to illustrate what you are seeing? I do not see a "Checkmark" on Mac or Windows. 
Photo of fabricedlc

fabricedlc

  • 1 Post
  • 0 Reply Likes
having the same issue and this is really very annoying.folder gets docked during import and then the next time you have to start all over again.

Photo of Robert Somrak

Robert Somrak, Champion

  • 726 Posts
  • 227 Reply Likes
This apparently doesn't work anymore.  I forgot about this feature and just tried it and I get the same results as you.  See here for a recent report

https://community.adobe.com/t5/lightroom-classic/why-don-t-docked-folders-stay-docked/td-p/9733653?p...


Photo of Mayuri Jain

Mayuri Jain, Employee

  • 90 Posts
  • 36 Reply Likes
Hi,

We are able to replicate the issue. We have logged a bug for the same. We will keep you posted for further updates.

Thanks
Mayuri
Photo of Lance Van de Vyver

Lance Van de Vyver

  • 4 Posts
  • 0 Reply Likes
This would be a huge win for me....i always import from the same folder as part of my work flow, but if i accidentally plug in a memory card or new hard drive etc lightroom forgets all about my docked folder. If its docked it should ALWAYS be default, even if a card etc is inserted
Photo of Matt Jones

Matt Jones

  • 2 Posts
  • 0 Reply Likes
Ugh same problem here, when I Import photos, the Docked folder is forgotten, and I have to click through 5-7 folders, all the way from Root through Users, Username, Pictures, Photos, 2020, April...finally arrive at the folder where I want to deposit the new photos. 
Then next session, I have to do it all over again, even if I Dock the folder above.  It forgets it every time.
Please help!
Photo of Alan Bailward

Alan Bailward

  • 37 Posts
  • 3 Reply Likes
Just adding my voice here as well, having the same issue the last while, I haven't been shooting much lately because of the lockdown, so I've only noticed it the last couple of days.  Same thing, have to click through my folder hierarchy to get to the folder I import to each time I import.  Right click on it -> Dock folder doesn't save for the next import (even in the same session and not having restarted LR Classic).  Hope this can be fixed in the next update.

Edit - This is now a 4 month old post with an 'acknowledged' tag for what would seem to be a pretty important issue for workflow and importing.  I have 6 or so levels of folders that I have to go through every time I import just so I can get my photos into the right folder.  I know no one from Adobe actually seems to monitor these, but it'd be *really* nice to see this fixed soon before I go insane.
(Edited)
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 7641 Posts
  • 1741 Reply Likes
Version 9.3, an update to Lightroom Classic, went live on June 15, 2020 and contains a fix for this issue. Please install the update and respond back if it does not cure the issue for you. Thank you for your patience!
Photo of Lance Van de Vyver

Lance Van de Vyver

  • 4 Posts
  • 0 Reply Likes
Hi Rikki,

Updated....same issue. Any new drive plugged in jumps to that, and then goes back to default "all drives" instead of previously docked folder :(
Photo of Mayuri Jain

Mayuri Jain, Employee

  • 90 Posts
  • 36 Reply Likes
Hi Lance,

Can you provide some more details on the issue that you are facing? 

1) Steps to replicate with details on import source and destination details?
2) System info

Thanks
Mayuri
Photo of Lance Van de Vyver

Lance Van de Vyver

  • 4 Posts
  • 0 Reply Likes
So if I am working within lightroom and I plug a card in my import box doesn't open (I have dissabled it because I am often working and importing images to my computer at the same time, so this is great).

However, if I then forget to eject the card and push import, lightroom goes to the default import preset of showing all sources on the left hand panel....kind of expected.

I realise my mistake, cancel the import.....closing the import box. Remove card reader. Click import again, and I have now lost my docked folder....it is back at the start position of showing all sources......in my case Local disk (c), New Volume (D), New Volume (E).

:(
Photo of Mayuri Jain

Mayuri Jain, Employee

  • 90 Posts
  • 36 Reply Likes
Hi Lance,

We are able to replicate the issue following your steps. Basically dock folder setting is reset when SD card is inserted and then removed. I will discuss the issue internally with the team and will get back to you.

Thanks
Mayuri
Photo of Alan Bailward

Alan Bailward

  • 37 Posts
  • 3 Reply Likes
This is working for me now it seems.  Glad this one is finally done. 

Edit: However it seems to *not* be docked when I import by 'copy' from a local folder instead of when I put in an SD card.

Sorry @Lance that it's not changed for you :(
(Edited)
Photo of Lance Van de Vyver

Lance Van de Vyver

  • 4 Posts
  • 0 Reply Likes
I'm glad it has worked for you!

I do so much run and gun editing and exporting for media in minimal time that I simply cannot do the import through a cable to a location, whilst rendering previews and trying to edit on a laptop in the field.