Photoshop CC: "Could not complete your request because of a program error" on startup

  • 1
  • Problem
  • Updated 5 months ago
  • Solved
  • (Edited)
When I go to start photoshop I get this error message pop up.

I'm using cs6 web premium installed as part of a site licence on my education department supplied laptop running win7 (so no install cd etc... We install off a network download)

I recently installed Grisoft AVG Trial antivirus after which the error started to appear. That is the only major change to the system. At this time I also got an "error 5" on computer boot up for Adobe Distiller and Adobe Acrobat Pro X. I have since uninstalled Acrobat Pro X as I've never used the App once which has removed this error message naturally, but the Photoshop error message remains.

I have since uninstalled the Grisoft AVG... The error message remains.

When I click OK, the message goes away and everything in photoshop appears to work normally. I can open, save, modify, re save, open the mini bridge, use all the features I regularly use for files etc. but every time I open photoshop I get that error message pop up.

Any ideas on what's going on and how to fix it?
Photo of Sean Ellery

Sean Ellery

  • 6 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 768 Reply Likes
Possibly something has messed up Photoshop's preferences.

Try resetting Photoshop's preferences on launch (by holding down control-alt-shift as you launch the app).
Photo of Sean Ellery

Sean Ellery

  • 6 Posts
  • 0 Reply Likes
Hi Chris! We know each other from the gutterzombie forum days...!

Ok, I'll try that and get back to you on the result

Cheers
Sean
Photo of Sean Ellery

Sean Ellery

  • 6 Posts
  • 0 Reply Likes
Hi Chris,

Yeah sure that solved the error message - but ONLY for that instance of opening Photoshop.

If I simply open it as usual without the ctrl-alt-shift, I get the error message back again...

Any other ideas? :)

cheers
Sean
Photo of Jeffrey Tranberry

Jeffrey Tranberry, Sr. Product Manager, Digital Imaging

  • 13977 Posts
  • 1671 Reply Likes
Might be permissions related. Or perhaps the anti-virus is modifying one of the required files or the preferences.

If you run in a new admin user or in safe mode does it operate without the error?

A copy of the error log "PSErrorLog.txt" might also help. It's location on your system is as follows: Windows: Users/[user name]/AppData/Roaming/Adobe/Adobe Photoshop CC 2015/Adobe Photoshop CC Settings/PSErrorLog.txt
Photo of Sean Ellery

Sean Ellery

  • 6 Posts
  • 0 Reply Likes
I'm not running a CC version of CS6... this is a network site installed version supplied by my employer.

My pathway is --> Users/[user name]/AppData/Roaming/Adobe/Adobe Photoshop CS6/Adobe Photoshop CS6 Settings/PSErrorLog.txt

At any rate here's the error log. It is somewhat...repetitive.

2015:10:17 21:09:41 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed2015:10:17 21:09:41 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:41 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:41 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:41 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:47 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:47 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:47 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:47 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:47 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:48 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:49 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:49 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:49 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:49 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:49 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:49 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:49 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:49 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:49 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:49 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:50 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:50 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:51 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:51 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:10:17 21:09:52 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:34 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:34 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:34 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:34 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:34 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:34 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:34 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:35 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:35 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:35 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:35 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:35 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:35 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:35 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:35 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:35 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed
2015:12:24 22:25:35 : ..\..\sources\UTextFace.cpp : 3497 : REQUIRE failed

cheers
Sean
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 764 Reply Likes
OK, so a corrupt font or OS font cache is causing the problem.
See this page for how to troubleshoot those: https://helpx.adobe.com/photoshop/kb/troubleshoot-fonts-photoshop-cs5.html

You also might avoid it by turning off font previews (and that will be saved in preferences).
(Edited)
Photo of Sean Ellery

Sean Ellery

  • 6 Posts
  • 0 Reply Likes
Absolutely NONE of these solutions worked!

1. Can't update to latest version. Option isn't there in the first place and I'm not using a CC photoshop anyway. Mine is an installed from a network (presumably originally on a CD...) site licence from my employer...

Options 2 - 6 - Had no effect. Error message remains

Option 7 - Can not delete all the fontcache files in that location though I got rid of some. 3 remain as computer claims they are in use by the computer. Either by Browser or by Win Explorer (I have to see the drive with *something* to delete them!!) These remaining files include --> 

~fontcache-fontface.dat
~fontcache-S-1-5-21-1263277996-903961532425476139-1002.dat
~fontcache-System.dat

Option 8 - I'm on win 7 laptop and not a Mac so this option doesn't apply to my situation.

.....

So OK... the error message remains... what's next?

cheers
Sean

Follow up... I turned my laptop off. Went to turn it back on and now it simply hangs on boot up. I can't even get to the user login screen now. The only changes made to the system are what I did following your help sheet such deleting the fontcache.dat files

So now I have that to deal with somehow first... Not happy!

Sean
(Edited)
Photo of Chris Cox

Chris Cox

  • 20280 Posts
  • 738 Reply Likes
The font change would not have prevented system boot.
Something else was probably going on with your system (disk going bad, malware, etc.).
Photo of Sean Ellery

Sean Ellery

  • 6 Posts
  • 0 Reply Likes
Had to re-image the machine back to original specs and reinstall EVERYTHING to deal with the hanging login/bootup.

Now have a squeaky new install of CS6 of course, so the issue is now resolved... so to speak
Photo of ch2012

ch2012

  • 1 Post
  • 0 Reply Likes
i have this in my error file (CC on Windows)
ULinkManager.cpp : 290 : REQUIRE failed
i was able to open the file with another editor (Paint.net) only problem is the PSD plugin of this editor converts texts into images