Lightroom problem with UserComment and XPComment EXIF fields

  • 1
  • Problem
  • Updated 3 years ago
  • (Edited)
Hi,

When you add a comment to an image file in Windows Explorer, this comment is written in the EXIF:XPComment field in the metadata. When Lightroom writes the field "User Comment" in a TIFF file, is also writes it to the EXIF:XPComment field. But when Lightroom *reads* the user comment from the metadata (when importing a file or when updating the metadata from the file) it reads the comment from the EXIF:UserComment field, which is totally inconsistent.

Until this bug is fixed, the solution is to copy the XPComment field to the UserComment field either for an individual file or for all files in a folder by using a tool like Exiftool. Once this is done, Lightroom will correctly display the user comment in the metadata panel.
Photo of Patrick Philippot

Patrick Philippot

  • 289 Posts
  • 42 Reply Likes
  • frustrated

Posted 3 years ago

  • 1
Photo of Patrick Philippot

Patrick Philippot

  • 289 Posts
  • 42 Reply Likes
To be more accurate about the Exiftool solution :

1. Install Exiftool and ExiftoolGui

http://www.sno.phy.queensu.ca/~phil/e...
http://u88.n24.queensu.ca/exiftool/fo...

2. In the ExiftoolGui browser, select the files to be processed.

3. Click on the Exiftool Direct button.

4. Enter the following command in the Command field:

-UserComment<XPComment

5. Press Enter

For all the target files, the XPComment comment field will be copied to the UserComment field. Then when importing these files or when reading the metadata from the file, Lightroom will correctly display the User Comment in the metadata panel.