Lightroom Classic: "An internal error has occurred: ?:0: attempt to index a nil value"

  • 83
  • Problem
  • Updated 1 month ago
  • (Edited)
When I delete photographs from catalogue + disc, I am now consistently having the following error dialogue box pop up in LR Classic CC:

"An internal error has occurred: ?:0: attempt to index a nil value"

It appears that LR is carrying out the delete function, however, in order to continue using the program, there is an "OK" checkbox that you must click on.
Photo of Brian Kipnis

Brian Kipnis

  • 8 Posts
  • 1 Reply Like
  • slightly annoyed

Posted 2 years ago

  • 83
Photo of Anna Dunphy

Anna Dunphy

  • 1 Post
  • 0 Reply Likes
I'm encountering this error as well. The error showed up after I did some file renaming outside of LR and cleaning up in LR.  I have 14 "phantom" images which show as blank images with no filename associated in Library & Develop. The count in my folder (731) is correct but the count for All Photographs (745) is incorrect at 14 more than exist in the folder. I have tagged these blank photos and tried to delete but end up with that error listed on this bug. I have disabled all plugins, reset preferences, done a backup with integrity checks and any other recommended solution. I have more images to import to this catalog but am concerned about the integrity.  Would appreciate some advice on how to get rid of these phantom images.

My System info:
Lightroom Classic version: 8.2.1 [ 1206193 ]License: Creative Cloud
Language setting: en-CA
Operating system: Mac OS 10
Version: 10.14.2 [18C54]
Application architecture: x64
Logical processor count: 4
Processor speed: 3.4 GHz
Built-in memory: 16,384.0 MB
Real memory available to Lightroom: 16,384.0 MB
Photo of Merk


  • 5 Posts
  • 1 Reply Like
This sounds similar to what happened to me - (you can see my post and solution on page 2). I have two suggestions you can try to fix this.

1. In LR, go into whatever folder LR thinks these images should be in and try deleting or renaming them while you in that folder. 

2. if the above doesn't work, try replacing/renaming whatever files LR thinks are missing. You said they show as blank with no file name, so not sure if you can do that since it's not telling you what file it's looking for.
Photo of Craig Cacchioli

Craig Cacchioli

  • 1 Post
  • 0 Reply Likes
This issue was only happening on my laptop and not my desktop. The only difference being that I chose to set Back up Catalog to "Never" because I don't need to back it up. When I set it to anything else the error message disappears, therefore the best worst alternative for me is to back up the catalog once a month. Solved.
Photo of Francesco


  • 7 Posts
  • 2 Reply Likes
Photo of Gordon Court

Gordon Court

  • 2 Posts
  • 0 Reply Likes
It's also got an incredibly slow on Startup and just the last week or two. Still getting these no errors whenever I try to delete a photo from disc. But takes upwards of five minutes to Startup from scratch. Nothing has changed except for the recent upgrade of version in Lightroom CC and I'm running Windows 10 on a MSI machine with 32GB Ram and a high-end Nvidia gaming card. Should be blazing fast but since I started using Photoshop with Lightroom, it's been a nightmare.
Photo of John R. Ellis

John R. Ellis, Champion

  • 5123 Posts
  • 1452 Reply Likes
Do the menu command File > Plug-in Manager and see if the Logitech plugin is installed (it gets installed automatically with other Logitech utilities). If it is, disable it or remote it entirely.