[7.3.1] Images to not render correctly unless zoomed in and back out again

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
Merged

This conversation has been merged. Please reference the main conversation: Lightroom Classic: GPU rendering will not complete in Develop Mode at Fit/Fill zoom levels

Hardware environment

CPU: Intel Core i7-3770K
GPU: MSI NVIDIA GeForce GTX 670 (391.35)
RAM: 16GB

Software environment

Windows 10.0.16299
Lightroom Classic CC 7.3.1

Problem description

After updating to Lightroom Classic CC 7.3.1, images to not load correctly:





Workaround

Zoom in and then out again:



Disabling the graphics processor does not solve the problem: Edit → Preferences... → Deselect "Use Graphics Processor".

Updating to NVIDIA driver 397.64 does not solve the problem.

Testing description

Reproduced in Lightroom Classic CC 7.3.1. Issue can be reproduced reliably upon restarting the computer.

Best regards,

Louis Vallance
Photo of Louis Vallance

Louis Vallance

  • 5 Posts
  • 0 Reply Likes
  • Frustrated

Posted 2 years ago

  • 1
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1712 Posts
  • 592 Reply Likes
Official Response
Photo of Louis Vallance

Louis Vallance

  • 5 Posts
  • 0 Reply Likes
Hi Simon,

This could be the same issue. After disabling "Use Smart Previews instead of Originals for image editing" the issue is fixed. Building smart previews in the Library module also fixes the problem ahead of time.

I'm guessing this is a bug since I had the option checked so t he smart previews should have been build automatically(?)
Photo of Simon Chen

Simon Chen, Principal Computer Scientist

  • 1712 Posts
  • 592 Reply Likes
You can still keep the "Use Smart Previews instead of Originals for image editing"  on if that is the workflow that you prefer, just ignore the spinning icon for now. It will be fixed in the next Lr update. In the case of missing Smart Previews, Lightroom will read (and populate if necessary when original is available) an equivalent of Smart Preview from the Camera Raw cache. Previously in this scenario, Lr would show a missing photo error. 
Photo of Victoria Bampton - Lightroom Queen

Victoria Bampton - Lightroom Queen, Champion

  • 5496 Posts
  • 2192 Reply Likes

This conversation is no longer open for comments or replies.