Lightroom Classic: ?:0 table index is nil

  • 1
  • Question
  • Updated 1 week ago
  • Answered
  • (Edited)
I keep getting the error: ?:0 table index is nil when I try to start Lightroom Classic. I have had this issue for around a month now. I send crash to Adobe but so far have not gotten a response. I have tried the suggestions on the support forum but those have not worked either. I have uninstalled/reinstalled Lightroom several times as well as reformatting my PC hard drive, with no success.
Photo of James Holland

James Holland

  • 2 Posts
  • 0 Reply Likes

Posted 2 weeks ago

  • 1
Photo of Guido Weerenbeck

Guido Weerenbeck

  • 10 Posts
  • 1 Reply Like
I am having the same error-message on my Mac when trying to delete an export-service.
Having this issue since version 8 I think...
Photo of Rikk Flohr

Rikk Flohr, Official Rep

  • 6710 Posts
  • 1514 Reply Likes
A Preference File will survive a Lightroom uninstall/reinstall. Sometimes weird behavior is corrected/cured by resetting the preferences.

Reset Procedure:

1. Close Lightroom.
2. Hold down [Alt/Opt]+[Shift] while restarting Lightroom.
3. Overwrite the Preferences when prompted by the dialog.
4. Close Lightroom.
5. Restart Lightroom.

Does the behavior continue after resetting the preferences?
Photo of James Holland

James Holland

  • 2 Posts
  • 0 Reply Likes
Thank you. I was able to launch Lightroom using those commands. Is there a reason why this happens?