Skip to main content
Adobe Photoshop Family

1 Message


80 Points

Sun, Jan 19, 2020 10:59 PM

Photoshop: Script error mystery

I have two Photoshop scripts which worked perfectly for several years ... until today.

However, upon updating to Photoshop 2020 today, when running one of the scripts, I receive the error "Error: General Photoshop error occurred. This functionality may not be available in this version of Photoshop. The command "Select" is not currently available."

However, the second, almost identical script — which varies only by one line! — runs fine.

The line in the script which *does* work is app.doAction("shop - 1920 it (@2x)", "shop"); and in the newly problematic one it is app.doAction("1920 it (@2x)", "S.L.H Check");

Otherwise they're identical in every single way.

(The scripts output images of varying sizes for my website.)

Both scripts worked fine in CS6 and CC 2019, but 2020 is a no-no.

Can anyone please advise?


125 Messages


2K Points

9 months ago

With scripts I've programmed, I get that error when I have not selected the layer that the script is trying  to process or the layer is not visible.  Check the layer panel to make sure the visibility eye is selected and the layer is selected.  This is a common occurrence when I'm in a hurry.



623 Messages


14.6K Points

9 months ago

Have you tried running those actions manually from the actions panel? I suspect there is a step in the action itself that's breaking. That might shed some light on the issue. Or at least give a clue what is breaking.