Skip to main content
Adobe Photoshop Family

158 Messages

 • 

4.2K Points

Sun, Jan 27, 2019 9:04 PM

Solved

Photoshop: Open CL greyed with current Nvidia driver (417.71)

Open CL functionality is greyed in Photoshop CC (both 2018 v19.1.7 and 2019 v20.0.2) with the latest Nvidia driver version 417.71 for Geforce GPUs (I use a GTX1080).

Stepping back through Nvidia's previous drivers shows that 416.34 works with Open CL in Photoshop but Open CL is greyed when switching to the next driver 416.81 and remains greyed on the current driver 417.71

I will raise a parallel report with Nvidia

Dave

Responses

Champion

 • 

1.6K Messages

 • 

28.2K Points

2 years ago

which OS?

158 Messages

 • 

4.2K Points

2 years ago

Hi
Windows 10 Pro (version 1803) 64 bit
Dave

Champion

 • 

1.6K Messages

 • 

28.2K Points

I'm running a 2070 with 417.35 and not having any issues... unfortunately i'm in the middle of a few projects, so i'm not able to test the update.

537 Messages

 • 

12.3K Points

2 years ago

Just to note and yes different graphics card from David's, mine is GTX 970 with driver version 417.71 and is working fine on my Windows PC. 

22 Messages

 • 

540 Points

2 years ago

Running 417.71 with a 1050Ti on Win 10 and all is well. OpenCL option is available and checked.

158 Messages

 • 

4.2K Points

2 years ago

Interesting and thanks all for your helpful feedback.

This afternoon I tried a few things. I went back through a series of NVidia driver updates and tested each .

398.11 Works with openCL
416.16 works with openCL
416.34 works with openCL
416.81 OpenCL greyed out - all other GPU functions OK
416.94 OpenCL greyed out - all other GPU functions OK
417.35 OpenCL greyed out - all other GPU functions OK
417.71 OpenCL greyed out - all other GPU functions OK

Disabling the GPUSniffer (by renaming it to ~sniffer.exe) made no difference.

The specific card is a Gigabyte GTX1080 Windforce OC 8G

For the time being I've stepped back to 416.34

Dave


158 Messages

 • 

4.2K Points

2 years ago

Finally - cracked it.

I once again updated to 417.71 but this time, in the Nvidia installation dialogue  chose "Advanced options" and checked "Clean install". It updated to the latest driver but this time Open CL is working correctly.

Thanks to all who fed back on their own systems - without that I would not have persisted with this. I hope the above helps anyone else who experiences something similar.

Dave

Adobe Administrator

 • 

14.9K Messages

 • 

286.1K Points

Uff-da. Those drivers can be pesky. Thanks for sharing the solution.

Sr. Product Manager, Adobe Digital Imaging

537 Messages

 • 

12.3K Points

2 years ago

That's so good David and good to know for the rest of us. Thanks.