Skip to main content
Adobe Photoshop Family

1 Message

 • 

90 Points

Mon, Nov 20, 2017 6:23 PM

Photoshop: No disk in drive error on launch

Latest startup bug since 2018 upgrade.
Photoshop.exe - No Disk
There is no disk in the drive. Please insert a disk into drive E.

Wow. I'm on Creative Cloud, Photoshop CC 2018. I now get this error when trying to open PS. I haven't seen an error like this since at least 1999. What the heck?

Responses

1 Message

 • 

60 Points

3 years ago

I'm having the same problem. I still haven't figured it out. Any luck?

14.6K Messages

 • 

282.6K Points

3 years ago

Hold down ctrl + all (win) or cmd + opt on launch of Photoshop. Try setting your scratch disk to your start-up disk.

14.6K Messages

 • 

282.6K Points

3 years ago

1 Message

 • 

60 Points

There is a bad recommendation in there to change a registry item. There is also a good suggestion that didn't work all the time for me. I'll try the Scratch Disk idea. thanks

1 Message

 • 

82 Points

2 years ago

I solved this by clearing my recent files list. Seems you open a file off a removable drive, it is then listed under recent, and then Photoshop tries to find the disk used on every launch.

2 Messages

 • 

72 Points

That is what I did. Especially when you update the version of Photoshop CC from the creative cloud app. Sometimes an option is given in the update to get rid of the old application and do a fresh install. I just opted for that moving up to 2019 version of Photoshop CC. When the app loads the new version it still tries looking for all the "recents" form the old version. Nothing is wrong its just looking at old paths that aren't there anymore. Clear recents list and no more issue. Just a little inconvenient to go fetch the photos manually 

1 Message

 • 

60 Points

2 years ago

Paul Wheeler's reply seems to answer my question...but it is frustrating that this is an issue. There needs to be an update to prevent this..even if it is just a "Don't show me this message again" checkbox. 

2 Messages

 • 

72 Points

2 years ago

Spike......you can go into your registry real easy and turn off the error message as you say you would like to do but it turns off all error msg. so a legit one won't get through either.  Its an option but not a good one. 

40 Messages

 • 

1.6K Points

a year ago

This issue appears to be solved by clearing your Recent File list, but we would like to fix the root problem. If anyone is still encountering this problem, please comment here or email Rajneesh at rchavli at adobe dot com.

138 Messages

 • 

2.6K Points

I am also experiencing this problem. Bridge is the latest version 9.0.3.279. I am running Win 7 Professional x64 fully updated. I have cleared the recent files list in the Files menu as well as the caches. This made no change to the problem. Once Bridge is completely launched it seems to work as expected.

1 Message

 • 

60 Points

a year ago

I have this issue