Skip to main content
Adobe Photoshop Family
S

2 Messages

 • 

80 Points

Tue, Nov 24, 2020 12:04 PM

Photoshop: My Artist tablet XP Pen Pro has issues after installing Windows 10

I have two computers. On both of them after installing windows 10, I have some issues on Photoshop with my Artist XP Pen Pro and even with my Wacom tablet.

For example, when I select a tool from my toolbox, it has 2 seconds delay. Or it has delay while picking up colors with eyedropper whenever I'm doing digital painting. Or when I select a part of an object and add another selection to my old selection, it does not add selection by using shift.

These whole situations are solved when I use mouse instead of my pen or when I uncheck "use window ink" on my Wacom tablet properties. But unchecking this item deactivates my brushes sensitivity.

I've uninstalled my windows 10 and installed it again with all the new updates. Uninstalled Adobe Photoshop and Installed older or newer versions so many times but nothing solved these problems. (now I'm using Adobe Photoshop 2019).

Any suggestion?

Responses

Employee

 • 

196 Messages

 • 

4.3K Points

2 months ago

While we don't officially support XP Pen, you can try some of the things listed here: https://helpx.adobe.com/photoshop/kb/tablet-support-faq-photoshop.html

Specifically using WinTab and changing some OS settings on Win10.

If these are old machines, it could be a graphics card issue (see if GPU is on or off in Preferences > Performance).  Make sure drivers are up to date (Wacom, XP Pen, Graphics card, etc)

2 Messages

 • 

80 Points

Thanks for the response. Unfortunately none of the solutions in that link helped. BTW my computer system has these features:

Intel(R) Core (TM) i7-4790K CPU @ 4.00 HZ  4.00 GHz

Installed memory (RAM): 16.0 GB

System type: 64-bit Operating System, x64-based processor

Pen and Touch: Pen Support

I used both of my pen tablet and Artist XP Pen, with Windows 7 on both of thoese computers with these features for four years and I had no problem. I'm pretty sure my problem is due to some new features (or maybe bugs) in Windows 10. But don't know whether they can be solved or not.