Skip to main content
Adobe Photoshop Family

4 Messages

 • 

282 Points

Sat, Nov 17, 2018 10:56 PM

Closed

Photoshop: Liquify bug is back in Mojave 10.14.2

Pixelation is back in photoshop. I’m enrolled in Apple beta releases and have the absolute latest Mojave 10.14.2Please help. I have SO MUCH work load.

This conversation has been merged. Please refer the main conversation:

Responses

Official Solution

14.6K Messages

 • 

282.6K Points

2 years ago

We're working with Apple to address this issue. See this article for details and workarounds: Black artifacts on image after using the Liquify filter

3 Messages

 • 

84 Points

The page doesn't seem to mention the problem being back with 10.14.2 specifically... Thank you for verifying this issue is on your radar anyway. I have to say it's a bit frustrating not to get any kind of official feedback for so long.

14.6K Messages

 • 

282.6K Points

Are you not able to see this?

3 Messages

 • 

84 Points

I stand corrected, I do see it now. Not sure if it was my browser showing me old content or just my eyes in need of a checkup ;-)

Thanks again for the information. Any ETA on a proper fix?

2 Messages

 • 

60 Points

3 months and still this issue exists?  I upgraded not know this would be a concern.  I mean yeah, you can turn off the graphics processor which is fine and all....but SUPER slow.  Come on guys!  This needs to be fixed!

62 Messages

 • 

1.4K Points

2 years ago

You must download Mojave in the app store (6 Go). It’s 10.14.1. Install it then disable auto update in update preference... Don’t go to 10.14.2 for now...

696 Messages

 • 

9.3K Points

2 years ago

Yes stay away from betas if you want to have a stable operating system.

4 Messages

 • 

282 Points

2 years ago

Thanks!

977 Messages

 • 

16.6K Points

2 years ago

This should be reported to Apple, not discussed here. Mojave beta releases are under NDA which means you agree to not discuss them.

3 Messages

 • 

86 Points

2 years ago

That's same error.
Apple, Are you kidding me? 

696 Messages

 • 

9.3K Points

Most likely it's actually something that adobe needs to fix in photoshop cc 2019 itself and it seemingly being fixed in the 10.4.1 update was just happenstance.

62 Messages

 • 

1.4K Points

2 years ago

Official Mac OS Mojave 10.14.2 is out and ... Liquify is out ! Grrrrr....
Stay on 10.14.1 !!!!!!!!!

2 Messages

 • 

90 Points

2 years ago

the only way if you dont have time machine to back to 10.14.1 its go back to high sierra.  i hope they fix this SOON!

3 Messages

 • 

84 Points

2 years ago

Yup, I can also confirm, the problem is back with 10.14.2. Come on Apple and/or Adobe, play nice!

2 Messages

 • 

104 Points

2 years ago

This reply was created from a merged topic originally titled 10.14.2 Mojave update and now Black/color artifacts on image after using the Liqu....

10.14.2 Mojave update and now Black/color artifacts on image after using the Liquify filter . I’ve also updated photoshop cc/LR/camera raw to most recent 2019 versions and still having this issue. Also my computer is super slow. Please help!!!

5 Messages

 • 

144 Points

2 years ago

This reply was created from a merged topic originally titled Black artifacts after liquify is back in Mojave 14.2.

I inadvertently upgraded to Mojave 10.14.2 the other day, and the same issue that plagued Photoshop at the release of Mojave (black artifacts after using the liquify tool) has returned. know upgrading to Mojave 10.14.1 originally solved this problem, but it looks like it has returned with 10.14.2... Anyone got any advice? Is there a permanent fix on the way so we don't have to keep dealing with this every other update? 



2 Messages

 • 

84 Points

2 years ago

This reply was created from a merged topic originally titled Liquify on Mac 10.14.2 still not fixed?.

Is there an update on this problem? Liquify is leaving pixels on images, I am running a Mac with latest update 10.14.2 can you please help fix this bug

5 Messages

 • 

144 Points

2 years ago

Has anyone been able to confirm if the latest update (version 20.0.2) fixes this issue?

62 Messages

 • 

1.4K Points

2 years ago

Bug not fixed in PS 20.0.2 with Mojave 10.14.2... (same with Mojave 10.14.3 last beta)

1 Message

 • 

66 Points

2 years ago

Incredible, it is still there mid of January!!