Skip to main content
Adobe Photoshop Family

4 Messages

 • 

102 Points

Tue, Jun 26, 2018 6:30 PM

Photoshop: Lagging refresh

For Months PS:CC has NOT been refreshing changes made with any tools. Just now, updated to latest cloud cc update and when changing font, had to go from character pallet to layers in order to "refresh" screen; stayed old font (STUCK IN TIME) until i changed something other than the font. This kind of crap has been happening with stamp tool and other tools over last few months. I pay extra, so that I dont have to worry about this kind of crap happening/ USING updated, newest software, makes me feel safe... or it used to. this is consistent across all macs. iMac 5K late 2014 (loaded/maxed out config) and 2016 MBPro(loaded/maxed out config) as well as my 2013 MBPro that i occasionally use. WHY?????? (High Sierra 10.13.5 updated OS and updated Creative Cloud always on all macs, before i do anything).

Responses

4 Messages

 • 

102 Points

3 years ago

I've used PS for 20 years that I'm conscious of. I would say that I'm an expert, but an "ex" is a "has-been" and  a "spurt" is a "drip-under-pressure", so I'm feeling a little displaced right now... Seriously, though, NO problems with PS EVER, until last 5-6 months, so I really am feeling a little worried about the program and I do own other alternatives, just NEVER opened them (it's a time management thing...). And now I'm getting into Ai for the first time since 10 and loving it. NO lags in Ai, Id... just Ps.

Adobe Administrator

 • 

15.8K Messages

 • 

295K Points

3 years ago

Do you have RightFont installed on your system?

Sr. Product Manager, Adobe Digital Imaging

4 Messages

 • 

102 Points

yes. is that a problem? meaning, have you seen that as a problem or conflict with adobe? because I have my second thoughts about using it... when I can get any font I want from sources... it seems a little tedious.

380 Messages

 • 

7.2K Points

3 years ago

Since you're seeing the lag across multiple machines, this sounds a lot like a software conflict of some sort. 

I'd go through Adobe's troubleshooting steps for plug-ins first: https://helpx.adobe.com/photoshop/kb/plug-ins-photoshop-troubleshooting.html

If that doesn't resolve the lag, try creating a new macOS X user account.

If you have a spare hard drive and you're up to speed on how to setup an external boot drive, this is the type of issue that I'd try creating a clean macOS X boot drive and clean Photoshop install to test.  

For what it's worth, the newest release is working as expected on all of my Macs.



-Warren

// Warren Heaton, ACP/UGM/AEL

4 Messages

 • 

102 Points

Thank you for your feedback. Its strange that all of my Macs are acting up (for sure the two newer ones are...) It was just today; a small file that I was replacing some text that was saved as .png file. I was cutting part of it off with marque and couldn't see change without going to another pallet from the one I was working on/ visa versa while typing the text, I was resizing it to match the previous height/size... so simple a task... and NOTHING until I went back to Layers pallet. Grrrrr. Thanks - I'll check out the link.

380 Messages

 • 

7.2K Points

It’s beyond frustrating when any application behaves unexpectedly.

How’a the troubleshooting going?

// Warren Heaton, ACP/UGM/AEL