Skip to main content
Adobe Photoshop Family

3 Messages

 • 

250 Points

Thu, Jun 28, 2012 8:30 AM

Photoshop: Keyboard shortcuts not working (CS6)

They work fine most of the time, then randomly they wont. It's only the single key shortcuts. (B for brush, Bracket keys, etc.)

*** Recently upgraded to CS6, never had the problem on 5.5***

Responses

Official Solution

Employee

 • 

96 Messages

 • 

2.9K Points

7 years ago

A plug-in to work around this issue is available at bit.ly/NzQly1 this plug-in works with both CS6 and CC.

15.1K Messages

 • 

195.8K Points

8 years ago

What OS version?

What kind of machine?

Have you tried another keyboard?

Do you have any utilities or drivers installed that would affect keyboard functionality (including tablets)?

3 Messages

 • 

250 Points

8 years ago

OSX 10.7.4 on a new macbook pro. I haven't tried another keyboard, and i do have a Wacom tablet.

15.1K Messages

 • 

195.8K Points

Someone else had a problem with the built-in keyboard not working correctly, but an external keyboard worked just fine. (and Photoshop doesn't know the difference between them, it just gets key events from the OS)

3.5K Messages

 • 

52.9K Points

Hiya Clayton,

We've heard of this before with other Wacom tablet users. I would be willing to bet money that if you disable the tablet, the problem will disappear. You should make sure you have the latest software and if the problem persists, report it to Wacom.

Thanks,
David

3.5K Messages

 • 

52.9K Points

Follow Up:

I just spoke with a few people and not only is the bug known, it has been reported to both Apple and Wacom.

Thanks,
David

2 Messages

 • 

72 Points

8 years ago

Just wanted to chime in to say that I have this issue too and am using an external keyboard on my Mac Pro.

I have noticed that when I keep repeatedly pressing the tool shortcut, for example pressing "A" for the path tool while I am on "V" move tool, that after say around 10-20 presses of "A" the path tool will activate itself.

It appears to perhaps be some form of extreme latency between the keyboard sending the keystroke from the OS to CS6.

Clayton, have you tried repeatedly pressing the shortcut you want? Does it eventually activate?

3 Messages

 • 

250 Points

8 years ago

I haven't tried that, but I did notice that it seems to happen after I change opacity or switch between my layer and it's mask. For example if I move something then switch to the mask and hit "B" for the brush it won't activate until I click somewhere outside the active layer.

1 Message

 • 

62 Points

8 years ago

I'm also having the problem (iMac i7, numpad keyboard). Never occured pre-CS6.
Sometimes it helps to hit the 'ESC'-key then press 'V' to activate move-tool.

3.5K Messages

 • 

52.9K Points

8 years ago

Are any of you, by chance, using any third party touch utilities or keyboard enhancers? Do you get this problem reliably?

2 Messages

 • 

72 Points

I do have a Wacom Bamboo Touch installed and connected to my Mac Pro.

Having said that, when the bug occurred the Wacom was not in use, merely connected to the machine.

I have the perception that this bug may have something to do with the FontFont 3rd party plugin. While I have no concrete evidence of this, it feels like this bug is often triggered after having used their plugin but I could be wrong about that.

3.5K Messages

 • 

52.9K Points

Howdy Jannis. If that's the case, please try disabling the plugin (renaming and moving it) and seeing if the trouble goes away. I cannot reproduce this in-house, so there is some piece missing.

11 Messages

 • 

272 Points

8 years ago

It appears I'm the first windows user here to report this. Most often it's when I use the cntl+bksp keys to change the mask of an ajustment layer. But I have also seen it when I use the single key commands like O and J.

Win7
Intel i7
Wacom intuous 4

3.5K Messages

 • 

52.9K Points

Howdy Edward,

First question is if all your drivers are updated. What about special apps to make use of the Wacom? You are the first Windows user to complain and on Win, drivers are commonly the issue. Also, can you get this problem reliably? I'm not seeing a problem on Win7 with CNTRL+Backspace. Could you list the steps you're doing and where things go wrong?

Thanks,
David

11 Messages

 • 

272 Points

Wacom and nVidia drivers are current.
No special apps using the Wacom
Other than Photoshop CS6, I1 profiler and a DVD burner program, there are no other applications on this machine.
Yes I can reproduce reliably.

Procedure:
(working with stylus)
Open Bridge
Select a DNG image
dTap thumbnail in Bridge (Film Strip mode)
ACR opens
Make several adjustments in ACR - or not, it doesn't seem to matter
Tap Open Object (my default preference)
Photoshop launches
Smart object layer appears.
Tap adjustment layer icon on Layers Panel - menu appears
Tap
Tap OK (accept foreground color)
Solid color layer appears on top of stack
Tap Blend Mode selection box on layers panel - Tap
Tap Adjustment Layer Mask thumbnail
Press Cntl + Bksp
Nothing happens
So I try Shift + F5
Nothing happens
Try other keyboard shortcuts like O,B,S or J
Nothing happens so I go to Properties (Masks) panel and tap invert twice.
Yes, this works!, so I tap Edit>Fill on the toolbar
Yes, this also works!.
Again I press Cntl+Bksp
Now it works fine
Again I press Shift+F5
Now it works fine too
Now other keyboard shortcuts also work.

So I tried some other adjustment layers too. The same problem happens IF the first thing I do after creating the adjustment layer is change the blend mode. It doesn't seem to matter which blend mode or which kind of adjustment layer. HOWEVER, if I leave the blend mode at Normal (don't immediately change it) all keyboard shortcuts seem to work fine.

Champion

 • 

881 Messages

 • 

19K Points

Any additional panel installed in Photoshop?

11 Messages

 • 

272 Points

No

11 Messages

 • 

272 Points

But I do have a customized workspace where I have removed the adlustments panel. I find it is redundant in CS6. That shouldn't matter however.

I have reduced the problem to be:
After creating a new adjustment layer and immedicately changing the blend mode the keyboard shortcuts fail to operate.

4 Messages

 • 

84 Points

8 years ago

I'm experiencing a very similar issue where keyboard shortcuts (single letter shortcuts that is - i.e. B for Brush Tool) is pressed the tool switches for about 1 second before switching back to the previous tool.

I've discovered this to be Typinator which is causing the issue. I guess it may be the same for similar text expander products as well.

Hope this helps!

4 Messages

 • 

84 Points

8 years ago

Hi guys,

I'm experiencing a similar issue in that the single keyboard shortcuts work but after about a second they switch back to the previous tool selected.

I'm running OS X 10.8 but was also experiencing this issue with the latest version of 10.7. I'm not running any addons and don't have an peripherals connected other than an Apple mouse and keyboard.

I have identified that this issue is only occurring on specific files. The files in question are all large files with a lot of layers.

Ollie

15.1K Messages

 • 

195.8K Points

Are you sure you aren't holding down the shortcut key (springloaded shortcuts)?

4 Messages

 • 

84 Points

Nope, not holding them down.

3.5K Messages

 • 

52.9K Points

Howdy Ollie,

If this problem is limited to specific files, then I have two questions -- first, were any made/edited using the CS6 Beta and two, would you be comfortable sending me one of the files so I can try and replicate the problem?

Thanks,
David

4 Messages

 • 

84 Points

Hi David,

The file in questions wasn't created using CS6 beta, but was created using CS5. Interestingly whilst preparing the file to send over to you I noticed that by deleting any of the top level layer folders the shortcuts begin to work fine. When returning the file to its original state (by undoing) the problem returns.

Further investigation seems to indicate that switching to the type tool is where the issue most frequently occurs.

Unfortunately I can't send over the original file without stripping some of the contents.

Ollie

3.5K Messages

 • 

52.9K Points

This is starting to sound like either a file corruption issue or a problem with your fonts. What fonts are used in those top layers? Let me get my hands on a dropbox for you... And, when you're using the type tool, please note that all shortcuts are disabled until you commit the layer. This is As Designed.

3 Messages

 • 

80 Points

8 years ago

when i have the move tool selected my apple command key no longer gives me the hand tool and command + space no longer gives me the zoom tool. this has pretty much crippled me.

It happens on all files, with all keyboards and I've made no changes to my machine from when it was working fine.

Help!

3.5K Messages

 • 

52.9K Points

Hi John,

Can you let us know what OS, what version of PS, and what you were doing?

Just so you know, on Mac, holding down the COMMAND key doesn't give you the Hand tool, it gives you the Move tool (black pointer with four-way arrow, same as pressing V). Similarly, COMMAND + + shouldn't give you the Zoom tool, it should just zoom. As a result, I'm guessing you're running a different product or version than Photoshop CS6.

We need more info to help.

Thanks,
David

3 Messages

 • 

80 Points

You are right. i wrote down the wrong thing. hitting the space key did not give me the hand. command space was not giving me zoom. I am using CS6 on a Macbook Pro 2GHz Intel Core i7.
8GB 1333 MHz DDR3
OS version 10.6.8.

I restarted the machines several times and after 3 tries photoshop hand and zoom functions returned.

Those keys worked as expected for all other functions and applications so the issue was photoshop cs6 specific. Not sure what was causing it.

3.5K Messages

 • 

52.9K Points

Hi John,

So, is the problem now gone for you?

3 Messages

 • 

80 Points

Yes, restarting a handful of times seems to some how solved it.

1 Message

 • 

60 Points

8 years ago

I can have a fit!!!
Brand new photoshop CS6 hit 'D'for default black and white foreground and bachground and I get program error
Pick a color from swatches = program error
hit "x"for swap foreground = program error
PLEASE if anyone knows why - let me know

3.5K Messages

 • 

52.9K Points

8 years ago

Howdy Nic,

Can you please let us know what OS, what version of PS, and what you were doing? This could have many causes, many of which have nothing to do with Photoshop. It sounds like your color swatches might have become corrupt; did you install or remove any programs recently?

More info will help us help you.

Thanks,
David

1 Message

 • 

60 Points

8 years ago

i believe all the relevant keystrokes you seem to be looking for are listed at http://www.cs6shortcuts.com/photoshop...

3.5K Messages

 • 

52.9K Points

8 years ago

Any user can also generate their customized keyboard shortcuts by clicking:
Edit > Keyboard Shortcuts > and then click the Summarize button midway down on the right.