frank_sobol's profile

17 Messages

 • 

300 Points

Tue, Jun 16, 2015 3:21 PM

Photoshop: Error 21 with update to CC 2015

I get these errors in trying to update PS2015...Other CC Photoshop programs do update. Installed PS 2015 originally but now cannot up date it.ERROR: DW021: Payload {3FB7A108-368A-4849-A3F3-69571BAAC457} Photoshop Adobe Photoshop CC 2015 Support 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Payload {793C2BF7-A4FE-4608-91C9-9282C5801C21} Photoshop Adobe Photoshop CC 2015 Core 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Unsupported payload versions included

Responses

Official Solution

Adobe Administrator

 • 

15.9K Messages

 • 

296.4K Points

6 y ago

Please try the solution here to uninstall and reinstall the Creative Cloud desktop app: https://helpx.adobe.com/creative-clou...

1 Message

 • 

60 Points

This worked for me. The symptoms I had were that the update button (in the CC desktop) for PS CC 2015 didn't appear to do anything, on a MAC

Adobe Administrator

 • 

15.9K Messages

 • 

296.4K Points

6 y ago

Did you install the updates from the Creative Cloud update? Or did you download patchers directly and run them?

Adobe Administrator

 • 

15.9K Messages

 • 

296.4K Points

6 y ago

Also, what OS/version are you running on?

17 Messages

 • 

300 Points

6 y ago

Win7-64bit, SP1

17 Messages

 • 

300 Points

6 y ago

I was in CC and clicked update for 2015...installed up to 42% and then got the Error 21 message...Frank

3 Messages

 • 

100 Points

6 y ago

Same thing.

- Downloaded from Adobe CC
- OSX Yosemite 10.10.3

Adobe Administrator

 • 

15.9K Messages

 • 

296.4K Points

6 y ago

Very strange. If you completely restart the system ad try the updates again, does it work?

10 Messages

 • 

162 Points

6 y ago

I have the same error (OS win 8.1 64 Bit)

ERROR: DW021: Payload {3FB7A108-368A-4849-A3F3-69571BAAC457} Photoshop Adobe Photoshop CC 2015 Support 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Payload {793C2BF7-A4FE-4608-91C9-9282C5801C21} Photoshop Adobe Photoshop CC 2015 Core 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Unsupported payload versions included

Adobe Administrator

 • 

780 Messages

 • 

16.7K Points

6 y ago

We have a log collector tool -- helpx.adobe.com/creative-cloud/kb/cc-log-collector.html

Could those with this issue, use the collector tool and email me the .zip files you get?

petgreen [at] adobe [dot] com

Adobe Administrator

 • 

15.9K Messages

 • 

296.4K Points

6 y ago

If you go to the Creative Cloud app and click the gear icon in the upper right and choose Preferences... what does the version say?

The most current version should be: 2.1.1.110

2.1K Messages

 • 

32.2K Points

6 y ago

What version of the Creative Cloud desktop app do you have installed? Make sure this is fully up to date. The version should be 2.1.1.110. If you don't have this latest version installed, sign out of and back into the desktop app: https://helpx.adobe.com/creative-clou...

2.1K Messages

 • 

32.2K Points

If sign out/sign in doesn't cause the desktop app to update, try Solution 2 here: https://helpx.adobe.com/creative-clou...

10 Messages

 • 

162 Points

6 y ago

My creative cloud version is the actual version 2.1.1.110.
(German Version)

I also tried to delete the "opm.db" (your solution 2) and I made a new login to Creative Cloud.

Once more Photoshop CC (2015) has been completely downloaded by CC. Then it shows message "Extrahieren" (German message for Extraction) then by the Installation message it stops at 43% with "Installationsfehler" (error installation)

more information:
"ERROR: DW021: Payload {3FB7A108-368A-4849-A3F3-69571BAAC457} Photoshop Adobe Photoshop CC 2015 Support 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS"

ERROR: DW021: Payload {793C2BF7-A4FE-4608-91C9-9282C5801C21} Photoshop Adobe Photoshop CC 2015 Core 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Unsupported payload versions included

Same error as before!

Must I have to uninstall the Photoshop CC (2014) version?

Adobe Administrator

 • 

15.9K Messages

 • 

296.4K Points

No. Uninstalling the Photoshop CC (2014) version shouldn't affect this. Please send your log files to Pete Green (his post/instructions are above)

17 Messages

 • 

300 Points

6 y ago

Where do I find the log files? Thanks for the help...Frank

Adobe Administrator

 • 

15.9K Messages

 • 

296.4K Points

Use this tool to collect them: http://helpx.adobe.com/creative-cloud...

17 Messages

 • 

300 Points

Ok...I have the log file...How do I sent it to you? Doesn't seem to be a way to add a file or folder (e.g., desktop folder) to these replies...Frank

3 Messages

 • 

100 Points

6 y ago

These steps worked for me:

1) Log out of CC
2) Reboot machine
3) Log in to CC
4) Update CC (Should begin automatically upon login)
5) Install PS CC 2015

Adobe Administrator

 • 

15.9K Messages

 • 

296.4K Points

Did you every try just signing out and back in (without the reboot)?

3 Messages

 • 

100 Points

I did, but the update hung at 0% and made no progress.

2 Messages

 • 

150 Points

6 y ago

All 2015 apps installed properly EXCEPT Photoshop. It repeatedly gives the following error at 42%: (Win 8 x64) Tried above no change...

Exit Code: 21
Please see specific errors below for troubleshooting. For example, ERROR: DW021 ...

-------------------------------------- Summary --------------------------------------
- 0 fatal error(s), 3 error(s)

ERROR: DW021: Payload {3FB7A108-368A-4849-A3F3-69571BAAC457} Photoshop Adobe Photoshop CC 2015 Support 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Payload {793C2BF7-A4FE-4608-91C9-9282C5801C21} Photoshop Adobe Photoshop CC 2015 Core 16.0.0.0 of version: 9.0.0.7 is not supported by this version: 9.0.0.6 of RIBS

ERROR: DW021: Unsupported payload versions included

-------------------------------------------------------------------------------------