Skip to main content
Adobe Photoshop Family
billjunk's profile

89 Messages

 • 

1.5K Points

Tue, Dec 3, 2019 9:11 PM

Solved

Photoshop: Erroneous selection artifacts appear when using Select Color Range and Polygon Lasso Tool

I was editing a photo in Photoshop 21.0.1 using the "Select Color Range" tool, the "Rectangular Selection" tool, and the "Polygon Lasso" tool to select / isolate an irregular area that I wanted to adjust.  While refining the selection created by the "Select Color Range" tool several instances of an artifact that looked a lot like a boot appeared at various locations in the image and outside the area that had been selected.  I tried to remove these artifacts by using the "Rectangular Selection" tool set to remove or "-" the area marked.  That did not remove them.  Later I tried to remove small portions of each artifact which did work if I used 4 or 5 selections to do the removal.  I have managed to get the selection artifacts out of my selection.  I'm thinking that there may be some sort of memory usage conflict causing this problem.  Most of the artifacts appear in the area above the light colored sky in the uploaded image.  System is Windows 10 Home Premium with all updates installed.


Responses

Adobe Administrator

 • 

15.9K Messages

 • 

295.3K Points

a year ago

I'm not sure if that's erroneous. It looks like you're trying to use Color Range on the mask of the adjustment layer. If you select the bottom layer does Color Range work as expected?

Sr. Product Manager, Adobe Digital Imaging

89 Messages

 • 

1.5K Points

a year ago

There were some other strange things happening as well, so I uninstalled Photoshop and reinstalled it.  I've redone the selection that I'd been working on before the "artifacts" showed up and I think I did it in the same way as before.  It's been less than an hour but things now seem to be better.  Time will tell.  Thanks for the quick reply and suggestion.

89 Messages

 • 

1.5K Points

a year ago

After reinstallation of Photoshop all features appear to be working as expected. Must have been something corrupted during or post installation.

89 Messages

 • 

1.5K Points

a year ago

After reinstallation of Photoshop all features appear to be working as expected. Must have been something corrupted during or post installation.